LTIB can't find zlib package, using Ubuntu 11.10 and LTIB 9.1.1

cancel
Showing results for 
Search instead for 
Did you mean: 

LTIB can't find zlib package, using Ubuntu 11.10 and LTIB 9.1.1

2,749 Views
AdCmo
Contributor III

I installed LTIB to /opt/freescale using Ubuntu 11.10 and I am getting this error though I know I installed zlib.

i.e. I installed:

zlib1g,

zlib1g-dbg,

zlib1g-dev and

libghc-zlib-dev.

 

But I am still getting error below when I run:

 

./ltib -m config

 

ltib cannot be run because one or more of the host packages needed to run it
are either missing or out of date or not in ltib's standard path.  Please
install/upgrade these packages on your host.  If you have your own utilities
in non-standard paths, please add an entry into the .ltibrc file for example:

%path_std
/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/my/own/exes

Package                Minimum ver   Installed info
-------                -----------   ---------------
zlib                   0             not installed

Died at ./ltib line 1397.
traceback:
 main::host_checks:1397
  main:542


Exiting on error or interrupt

When I try to reinstall "zlib1g-dev" it says I already have the newest version.

I am using ltib 9.1.1 ($Revision: 1.445.6.1 $)

 

Also aptitude search cannot find zlib-devel.

Anything else I am missing?

Thanks,

Ad.

Tags (1)
0 Kudos
2 Replies

103 Views
Yuri
NXP TechSupport
NXP TechSupport

In perl script ltib (in the beginning) find lines

$cf = {

   # configuration options

    bldbase   => $top

    ...

    pre_install_deps   => "

      glibc      2.2.4

      ....

      zlib  0

and just comment (#) zlib related line.

The other dependencies (say, flex) may be commented in the same manner.

0 Kudos

103 Views
AdCmo
Contributor III

It was a bug in LTIB scripts not having correct binary path.

 

I had to edit ltib/bin/Ltibutils.pm

See similar post at:

http://forums.freescale.com/t5/i-MX-Microprocessors/i-MX51-LTIB-Ubuntu-11-04-x86-64-glibc-devel/td-p...

and the LTIB patch at:

http://lists.nongnu.org/archive/html/ltib/2011-07/txtB5I18k25M7.txt

 

Now I am off to another problem:

"Exiting on error or interrupt
Please see >> /opt/freescale/ltib/host_config.log for details"

Which is:

pmdb: --force-debian: unknown option
Died at ./ltib line 2340.
traceback:
 main::setup_rpmdb:2340
  main::check_rpm_setup:2403
   main::host_checks:1423
    main:542

 

Ad.

--------------------------------

0 Kudos