L5.4.3 BSP qca6174 compile faild

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

L5.4.3 BSP qca6174 compile faild

Jump to solution
681 Views
coindu
Contributor IV

Hi

      Build imx8mqevk image with L5.4.3 bsp, a error will appear about kernel-module-qcacld-lea on do_fetch stage.

     meta-imx\meta-bsp\recipes-kernel\kernel-modules\

      kernel-module-qcacld_3.1.inc

      kernel-module-qcacld-lea.inc

SRC_URI = "${QCACLD_SRC};branch=IMX_CNSS.LEA.NRT_3.0"
SRCREV = "7dc91e5977f31d60741c55682564788c0f930163"

 

     The branch and commit is not match, even if I change the branch name, it still compiles and reports errors.

      

coindu_0-1623380722818.png

coindu_1-1623380763997.png

 

 

    It seems that the BSP was not fully tested when it was released. 

 

     

Labels (1)
0 Kudos
1 Solution
670 Views
jamesbone
NXP TechSupport
NXP TechSupport

The driver of the QCA6174 it is not longer available, since NXP already has their own Wifi Module, but you can contact the module maker or directly with Qualcomm in order to get a driver for the Linux BSP that you are using.  But it is not integrated in our BSP.  I apologize for the inconvenience.

 

 

 

View solution in original post

0 Kudos
1 Reply
671 Views
jamesbone
NXP TechSupport
NXP TechSupport

The driver of the QCA6174 it is not longer available, since NXP already has their own Wifi Module, but you can contact the module maker or directly with Qualcomm in order to get a driver for the Linux BSP that you are using.  But it is not integrated in our BSP.  I apologize for the inconvenience.

 

 

 

0 Kudos