J-link not detected IMX6UL-EVK board

cancel
Showing results for 
Search instead for 
Did you mean: 

J-link not detected IMX6UL-EVK board

1,107 Views
sirrajrai
Contributor I

Hi,

I am using freescale IMX6UL-EVK board before few weeks.I have some new task to do with jtag now but unable to proceed due to jtag connection failure.

I have made  proper connection of JTAG with my board but  j-link is not detected my board.I downloaded windows jtag driver software from SEGGER - The Embedded Experts - Download  link but whenever i run JLinkGDBServer.exe in the installed driver folder it was unable to connect my board.I attached u the screen shot of this.

my question is

I am using SEGGER j-link EDU is it correct version of JTAG. suggest if any other is supporting.

if jtag version is proper than what is jumper setting i have to do.

0 Kudos
3 Replies

73 Views
dhvanil_patel1
Senior Contributor I

HI igor,

I want to access i.MX6UL CPU, fuze and boot register via JTAG interface. Can you please help me on How can access the i.MX6UL CPU register via JTAG interface on i.MX6ULEVK board?

Is J-Link software from SEGGER support the i.MX6UL board ?

-

Dhvanil

0 Kudos

73 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Sirraji

please look at jlink recommendations in How to Use J-Link to Debug i.MX Processors.pdf

on link:

ARM DS-5 Configuration for i.MX 6UL

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

73 Views
sirrajrai
Contributor I

Hi igor,

Thanks for reply

I followed the document provided by you. It is mentioned that JTAG is dedicated with Audio Codec signals. Therefore, in order to use JTAG debugging, several resistors need to be removed. More specifically, according to the above document, the resistors to be removed are R1407 and R1431 to R1434.

But I failed to find how to remove these resistors as these seems to be fixed on i.MX6UL Board. Kindly help me to provide appropriate way to remove them.

I appreciate your kind help.

Thanks,

Sirraj

0 Kudos