J-LINK is unable to connect with iMX6ULL EVK

cancel
Showing results for 
Search instead for 
Did you mean: 

J-LINK is unable to connect with iMX6ULL EVK

797 Views
bartosz_nowak
Contributor I

Hello Everyone,

I recently start to work with IMX6ULL EVK. I'm working with J-Link Base Firmware 6.22d (with 6.22c also don't work).

While i was trying connect JTAG debugger to board I came across some serious problem. I don't know why after removing resistors: R1407, R1431~R1434, I can't connect to core. Log is in attachment.

After some analys I figured it out that there is a daisy chain connection between some other components and according to Reference Manual 0x088C101D, IRLen: 04, JTAG-DP is a imx6ull core.

According to JLink wiki I've written the script which was selecting JTAG-DP from daisy chain (I was also trying to select CoreSight). After my many approaches to make some connection with this device, it is still don't work as it suppose to. Log from this is in Log_JLinkExeScript file.

Changing speed don't help. Changing booting modes don't help.

Right now I hitting the wall and don't have any idea what i should do to solve my problem...

I would be grateful for any help.

700-28616 REVA1

SCH-28616 REV C2

Labels (2)
4 Replies

286 Views
bartosz_nowak
Contributor I

I don't know if it was due to my post, or not, but day after it Sagger published new drivers (6.22e) which solved this problem. 

Also my friend managed to connect with this board with version 6.14h.

Release notes for the J-Link Software and Documentation Pack 

Cheers 

286 Views
sunmyfong
Contributor I

Thanks for ur info. With JLink_V622e, JLINK can connect to core successfully,but fail to download&debug app in IAR.

JLink_V614h works well in IAR System.  

0 Kudos

286 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hello Bartosz,

      After removing resistors: R1407, R1431~R1434,  please populated resistors: R1910, R1911, R1912,R1913,R1914.

Then, try it again!

Have a nice day!

TIC Weidong Sun

0 Kudos

286 Views
sunmyfong
Contributor I

Hello guys,

   I'm working with IMX6UL EVK & J-Link Plus Firmware 6.22d.

   after populating resistors:R1910, R1911, R1912,R1913,R1914,still can't connect to core.

   Any other ways?

Log:

Connecting to target via JTAG
TotalIRLen = 13, IRPrint = 0x0101

**************************
WARNING: At least one of the connected devices is not JTAG compliant (IEEE Std 1149.1, 7.1.1.d, IR-cells). (NumDevices = 3, NumBitsSet = 2)

**************************

JTAG chain detection found 3 devices:
#0 Id: 0x5BA00477, IRLen: 04, CoreSight JTAG-DP
#1 Id: 0x00000001, IRLen: 05, Unknown device
#2 Id: 0x1891D01D, IRLen: 04, JTAG-DP
TotalIRLen = ?, IRPrint = 0x..000000000000000000000000
TotalIRLen = 13, IRPrint = 0x0101

Cannot connect to target.

0 Kudos