Imx8mm: Could not initialize PHY ethernet@30be0000

cancel
Showing results for 
Search instead for 
Did you mean: 

Imx8mm: Could not initialize PHY ethernet@30be0000

478 Views
Contributor IV

Hi,

I am getting the below error, (log attahced)
---------------------------------------------------------------------------------------------------------------
u-boot=> ping 192.168.36.136                                                    
ethernet@30be0000 Waiting for PHY auto negotiation to complete......... TIMEOUT!
Could not initialize PHY ethernet@30be0000                                      
Using ethernet@30be0000 device                                                                                                                            
Abort                                                                          
ping failed; host 192.168.36.136 is not alive
-----------------------------------------------------------------------------------------------------------------
Please advice, how to resolve
Regards
Santhosh
0 Kudos
6 Replies

122 Views
Senior Contributor II

Hi Santhosh Kumar,

Some simple initial tips:

 

1. Make sure the cable is correctly connected to the right ethernet port on the board (there are several ports)

2. Make sure the host 192.168.36.136 is normally available, you may use a third host to ping to the 192.168.36.136.

3. Check Firewall settings on your PC.

4. Check if the PC can ping the board

5. Check the switch settings whether they are all in default position as the board quick start document.

You can refer to the below link. I hope it is helpful for you.

The u-boot of i.mx6q cannot ping the board itself 

Regards,

Radhika Somaiya.

0 Kudos

122 Views
Contributor IV

Hi Radhika,

I was able to resolve "ethernet@30be0000 Waiting for PHY auto negotiation to complete"  issue by setting the MAC address in uboot and now the uboot driver is able to detect the phy, but the ping is not working please find the below trace and advice how to proceed ahead

 

I have set the ipaddr to 192.168.36.15 and trying to ping the PC.

Note: The board is directly connected to PC instead of connecting to network switch and PC IP address is set to 192.168.36.136

u-boot=> ping 192.168.36.136

LVDS: phy_startup

LVDS: genphy_update_link

Using ethernet@30be0000 device

 

ARP Retry count exceeded; starting again

ping failed; host 192.168.36.136 is not alive

u-boot=> mii info

PHY 0x03: OUI = 0x80017, Model = 0x09, Rev = 0x00, 100baseT, FDX

u-boot=> mii device

MII devices: 'FEC0'

Current device: 'FEC0'

u-boot=> mii dump

0.     (ffff)                 -- PHY control register --

  (8000:8000) 0.15    =     1    reset

  (4000:4000) 0.14    =     1    loopback

  (2040:2040) 0. 6,13 =   b11    speed selection = 10 Mbps

  (1000:1000) 0.12    =     1    A/N enable

  (0800:0800) 0.11    =     1    power-down

  (0400:0400) 0.10    =     1    isolate

  (0200:0200) 0. 9    =     1    restart A/N

  (0100:0100) 0. 8    =     1    duplex = full

  (0080:0080) 0. 7    =     1    collision test enable

  (003f:003f) 0. 5- 0 =    63    (reserved)

 

 

u-boot=> mii read 0-1 0-6

addr=00 reg=00 data=FFFF

addr=00 reg=01 data=FFFF

addr=00 reg=02 data=FFFF

addr=00 reg=03 data=FFFF

addr=00 reg=04 data=FFFF

addr=00 reg=05 data=FFFF

addr=00 reg=06 data=FFFF

 

addr=01 reg=00 data=FFFF

addr=01 reg=01 data=FFFF

addr=01 reg=02 data=FFFF

addr=01 reg=03 data=FFFF

addr=01 reg=04 data=FFFF

addr=01 reg=05 data=FFFF

addr=01 reg=06 data=FFFF

Regards

Santhosh Kumar

0 Kudos

122 Views
NXP TechSupport
NXP TechSupport

Note: The board is directly connected to PC instead of connecting to network switch and PC IP address is set to 192.168.36.136

> do you get ip from PC instead of router? if you connect your board and PC to the same router, can you ping pc and board each other?

0 Kudos

122 Views
Contributor IV

Hi Joan,

Yes we can ping when host is directly connected to  board. This behaviour i have tested using I.MX8MM NXP EVK kit

Regards

Santhosh

0 Kudos

122 Views
NXP TechSupport
NXP TechSupport

so you have fixed your issue already, right?

0 Kudos

122 Views
Contributor IV

Yes I have Fixed it

Regards

Santhosh

0 Kudos