Imx6qp and CSI0 on L5.x

cancel
Showing results for 
Search instead for 
Did you mean: 

Imx6qp and CSI0 on L5.x

Jump to solution
268 Views
christophe
Contributor V

Hi everybody,

We have somee trouble to make csi capture work: Imx6qp board, parallel CSI0 capture 8 bits.

We have moved from Linux 4.1.15 to Linux 5.x (5.4 and 5.10). The capture works fine with L4.1.15 and not with L5.x.

 

We wonder why because the board is the same, the driver is the same (ov5640 style in spi), the user application is the same (compiled with L5.x sdk), the dts is the same. We use V4L2 interface.

As we directly monitor imx registers, we can see programmation is correct (the same), but with L5.x, no csi callback occurs:

 

[ 31.646319] In MVC: mxc_v4l_do_ioctl c0445611

[ 31.650693] case VIDIOC_DQBUF

[ 31.653939] In MVC:mxc_v4l_dqueue - wait_event_interruptible_timeout= 0

[ 32.404107] ERROR: v4l2 capture: mxc_v4l_dqueue timeout enc_counter 0

 

 

MACHINE=imx6qpstarlitex DISTRO=fsl-imx-fb source imx-setup-release.sh -b build

 

So, our question: is the simple CSI0 capture still working for imx6qp, under L5.x ?

 

Rgds,

Christophe

Labels (2)
0 Kudos
1 Solution
257 Views
igorpadykov
NXP TechSupport
NXP TechSupport

>you assert there's no CSI capture issue with imx6 in L5.x versions.

 

I checked internally, no issues were reported from other customers.

 

Best regards
igor

View solution in original post

0 Kudos
3 Replies
259 Views
christophe
Contributor V

Hi Igor,

We already use Aurora code and we rebuild everything.

So, you assert there's no CSI capture issue with imx6 in L5.x versions. This is the meaning of my question.

Rgds,

Christophe

0 Kudos
258 Views
igorpadykov
NXP TechSupport
NXP TechSupport

>you assert there's no CSI capture issue with imx6 in L5.x versions.

 

I checked internally, no issues were reported from other customers.

 

Best regards
igor

0 Kudos
262 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Christophe

 

>We wonder why because the board is the same, the driver is the same (ov5640 style in spi),
>the user application is the same (compiled with L5.x sdk), the dts is the same.

 

it may be different (drivers, dts, uboot and other software components) in new kernels,

so recommended to rebuild all image from scratch, not use old binaries.

Also may be recommended to try nxp linux from source.codeaurora.org/external/imx/linux-imx repository
https://source.codeaurora.org/external/imx/linux-imx/tree/?h=lf-5.10.y

Documentation:

https://www.nxp.com/design/software/embedded-software/i-mx-software/embedded-linux-for-i-mx-applicat...

 

Best regards
igor

0 Kudos