Image 'fsl-image-validation-imx' build failed

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Image 'fsl-image-validation-imx' build failed

2,184 Views
cgong
Contributor II

Image 'fsl-image-validation-imx' build failed due to "vkmark-1.0-r0 do_configure: meson failed". The log file shows "Meson version is 0.44.1 but project requires >=0.45."

I built this image about 2 months ago with success . I am not aware of any changes since then. The BSP releases are L4.14.62_1.0.0_beta and L4.14.98_2.0.0_ga.

2 Replies

1,504 Views
mamorukanou
Contributor IV

Hi, Chad

I also encountered the same problem when rebuilding recently.

My BSP version is L4.14.98_2.0.0_ga.

I changed following file: modified meson_version

- FILE NAME:

   tmp / work / aarch64-poky-linux / vkmark / 1.0-r0 / git / meson.build

- MODIFICATUIONS:

   <before>

         project (
             ‘vkmark’,
             ‘cpp’,
             default_options: [‘cpp_std = c ++ 14’],
             version: ‘2017.08’,
             meson_version: ‘> = 0.45’
             )

   <after>

        project (
             ‘vkmark’,
             ‘cpp’,
             default_options: [‘cpp_std = c ++ 14’],
             version: ‘2017.08’,
             meson_version: ‘> = 0.41’
             )

As a result,  I was able to build anyway.

BR,

kanou

1,504 Views
cgong
Contributor II

Hi Kanou,

Thank you for the reply. I tried your method, and it works. Also, I found that if I remove packages of packagegroup-fsl-tools-gpu-external and vkmark by adding the line IMAGE_INSTALL_remove += " packagegroup-fsl-tools-gpu-external vkmark" in local.conf, the build will bypass vkmark to end up a successful build.

Back to an earlier successful build, in the same 'project' structure in meson.build as you refer in the reply, there is no such a line of " meson_version: >=0.45". Perhaps that is why there was no problem earlier.

I don't know what are behind this. I guess we have the temporary solution. But the root cause is still unknown.

Regards,

Chad