IMX8MQ EVK: No data on MIPI DSI interface

cancel
Showing results for 
Search instead for 
Did you mean: 

IMX8MQ EVK: No data on MIPI DSI interface

1,890 Views
jignesh1
Contributor I

We are going to make product based on IMX8MQ (MIMX8MQ6DVAJZAA) processor.  Currently we are doing POC on IMX8MQ processor EVK.

  • We have connected kingsfield LCD (800 x 1280). It has driver IC (ILI9881C) and it has MIPI-DSI interface.
  • We have connected  lcd directly using DSI interface provided on IMX8MQ EVK.
  • To verify this setup we are using "fsl-imx8mq-evk-dcss-rm67191.dtb".  We have modified this device tree to support LCD panel we are using.  Following is snippet of device tree modification.

&mipi_dsi_bridge {
        status = "okay";

        panel@0 {
                compatible = "bananapi,lhr050h41", "ilitek,ili9881c";
                reg = <0>;
                reset-gpios = <&gpio5 6 GPIO_ACTIVE_HIGH>;
                port {
                        panel1_in: endpoint {
                                remote-endpoint = <&mipi_dsi_bridge_out>;
                        };
                };
        };
        port@1 {
mipi_dsi_bridge_out: endpoint {
                        remote-endpoint = <&panel1_in>;
                };
        };
};

Following is snippet of driver change: (drivers/gpu/drm/panel/panel-ilitek-ili9881c.c)

        dsi->mode_flags = MIPI_DSI_MODE_VIDEO | MIPI_DSI_CLOCK_NON_CONTINUOUS | MIPI_DSI_MODE_VIDEO_HSE;
        dsi->format = MIPI_DSI_FMT_RGB888;
        dsi->lanes = 4;

  • Issue is we are getting clock coming out of IMX8MQ processor or DSI interface of processor but there are no data on data lines. We measured it on EVK itself and we don't see any data on data lines.

Are we missing anything? Any suggestion or direction will be appreciated.  As we are in critical phase of our project any help will be appreciated to proceed further.

Let me know if any information is required from us.

Thanks,

Jignesh

Labels (1)
Tags (1)
0 Kudos
5 Replies

811 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Jignesh

also one can check lcd timings defined in struct display_timing rad_default_timing[] in

linux/drivers/gpu/drm/panel/panel-raydium-rm67191.c

panel-raydium-rm67191.c\panel\drm\gpu\drivers - linux-imx - i.MX Linux kernel 

and lcd specific commands in /* Manufacturer Command */
static const cmd_set_table manufacturer_cmd_set[]

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

811 Views
jignesh1
Contributor I

Hi Igor,

Yes timing parameter are okay and thought the timing parameter are incorrect. We should get some activity on MIPI DSI data lines.

Also I checked in panel driver that all panel function ".prepare" , ".enable" and ".get_modes" are called from driver. These function are writing something using MIPI DSI so there must be some activity on data lines.

Thanks,

Jignesh Patel

0 Kudos

811 Views
jignesh1
Contributor I

It was connection related issue, now everything is working correct.

0 Kudos

811 Views
harry18456
Contributor II

Hi Jignesh,

I have same problem with no data on data lane.

Could you kindly provide your solution?

Thank you.

0 Kudos

811 Views
trongthinh
Contributor IV

I have the same issue. could you share your connection? or show me what wrong with your connection. 

Many thanks.

0 Kudos