IMX8MDQLQ(MIMX8MQ6CVAHZAA) - USB not reconized for PC

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

IMX8MDQLQ(MIMX8MQ6CVAHZAA) - USB not reconized for PC

Jump to solution
271 Views
hspark
Contributor I

I'm currently making a board using MIMX8MQ6CVAHZAA and testing it.

The chip supports USB1,2 PORT, and I am trying to download an image through USB1, but it is not recognized in the device manager of the PC.

I tried several things, but there was no improvement. One suspicious thing is that USB2 Port is not used, so USB2_VDD33, USB2_VPH, USB2_VPTX, USB2_VP, USB2_DVDD, which are related to USB2, are not connected. Of course, I didn't connect it arbitrarily, I checked "i.MX 8MDQLQ Hardware Developer's Guide, Rev. 4, 04/2021" and didn't connect.

I wonder if I was misinformed or if there is an error in the guide document. I'm a bit depressed right now, please help.

0 Kudos
1 Solution
207 Views
riteshmpatel
NXP TechSupport
NXP TechSupport

Hi @hspark,

USB1 PHY and USB2 PHY are separate inside the i.MX8M. So, USB2 is not required to be powered for using the USB1 port.

To download through the USB1 port (USB Seria;l Download mode), BOOT_MODE0 should be high and BOOT_MODE1 should be low.

riteshmpatel_0-1685353973202.png

Thanks & Regards,
Ritesh M Patel

View solution in original post

4 Replies
255 Views
riteshmpatel
NXP TechSupport
NXP TechSupport

Hi @hspark,

I hope you are doing well.

Regarding this issue, it is recommended to check the below-mentioned points:

1. Please check if USB drivers are properly installed on the PC used for the connection.

2. Please check if the design complies with the recommendations mentioned in Table 11. USB recommendations in i.MX 8MDQLQ Hardware Developer’s Guide.

3. Please check the 24 MHz and 27 MHz crystal stability with respect to the recommendations mentioned in Table 13. Oscillator/Crystal recommendations in i.MX 8MDQLQ Hardware Developer’s Guide.

Thanks & Regards,
Ritesh M Patel

0 Kudos
233 Views
hspark
Contributor I

Thank you for your reply.
1. Please check if USB drivers are properly installed on the PC used for the connection.
=>Do I have to separately install the usb driver for windows 10 related to I.MX8M?
2. Please check if the design complies with the recommendations mentioned in Table 11. USB recommendations in i.MX 8MDQLQ Hardware Developer’s Guide.
=> It seems that the H/W was designed with reference to the document.
3. Please check the 24 MHz and 27 MHz crystal stability with respect to the recommendations mentioned in Table 13. Oscillator/Crystal recommendations in i.MX 8MDQLQ Hardware Developer’s Guide.
=> I also checked the CLOCK, but there seems to be nothing wrong.

Additionally, we checked the following:

As mentioned before, USB2 POWER was not connected in the USB-related circuit below.

 

스크린샷 2023-05-26 162117.png

Also, as in the GUIDE document, the USB2 signal lines were not connected as shown in the circuit below.

스크린샷 2023-05-26 162405.png

Looking at Figure 3. Power architecture on page 17 of the i.MX 8M Dual / 8M QuadLite / 8M Quad Applications Processors Data Sheet for Industrial Products document, it seems that USB1 PHY and USB2 PHY are separated inside the chip.

스크린샷 2023-05-26 163559.png

However, if you look at Table 84 on page 80, it says USB PHY, not USB1/2 PHY.

스크린샷 2023-05-26 164052.png

I am now using the BOOT_MODE0 and BOOT_MODE1 pins to set both pins to LOW to download through the USB1 port, but the device manager of the window11 PC does not recognize the I.MX8 USB1 port.

I think that USB2 POWER should be connected even if only USB1 PORT is used without using USB2 PORT.
Aren't USB1 PHY and USB2 PHY physically separated inside the I.MX8 chip?

0 Kudos
208 Views
riteshmpatel
NXP TechSupport
NXP TechSupport

Hi @hspark,

USB1 PHY and USB2 PHY are separate inside the i.MX8M. So, USB2 is not required to be powered for using the USB1 port.

To download through the USB1 port (USB Seria;l Download mode), BOOT_MODE0 should be high and BOOT_MODE1 should be low.

riteshmpatel_0-1685353973202.png

Thanks & Regards,
Ritesh M Patel

184 Views
hspark
Contributor I

Hi, riteshmpatel
Thank you for answer.
The cause seems to be a problem with the I.MX8 mounting when manufacturing the board.
Your answer helped me a lot.

Best regards,

hspark

0 Kudos