IMX8M : gstreamer give error on H264 stream

cancel
Showing results for 
Search instead for 
Did you mean: 

IMX8M : gstreamer give error on H264 stream

363 Views
fredericduchass
Contributor III

Hello,

I try to decode an MPEG2TS stream which is encoded with h264. I use the couple h264parse + vpudec and i get many many errors at the output :

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

.

.

.

.

Do you know what the reason and meaning of this error ?

BR

Frederic

Labels (1)
Tags (2)
0 Kudos
4 Replies

163 Views
joanxie
NXP TechSupport
NXP TechSupport

could you share your video and your gstreamer commands?

how about using "gplay-1.0" or "gst-launch-1.0 playbin uri=xxxx?"

0 Kudos

163 Views
fredericduchass
Contributor III

Hello,

This is the file which gives erros :

https://wetransfer.com/downloads/b5c30dbb879cb109989005e314f2d02320190129085753/2444c4783a2eac32cad7...

Even with playbin i get this error:

root@cl-som-imx8:/run/media/sda1# gst-launch-1.0 playbin uri=file:/home/sefram/out.ts
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...

====== AIUR: 4.3.5 build on Jan 21 2019 17:47:10. ======
Core: BLN_MAD-MMLAYER_MPG2PARSER_04.05.16 build on Sep 14 2017 02:37:53
file: /usr/lib/imx-mm/parser/lib_mpg2_parser_arm_elinux.so.3.1
------------------------
Track 07 [audio_0] Enabled
Duration: 0:00:11.136000000
Language: qaa
Mime:
audio/x-eac3, channels=(int)6, rate=(int)48000, bitrate=(int)999
------------------------
------------------------
Track 08 [audio_1] Enabled
Duration: 0:00:11.136000000
Language: fre
Mime:
audio/x-eac3, channels=(int)6, rate=(int)48000, bitrate=(int)999
------------------------
------------------------
Track 09 [audio_2] Enabled
Duration: 0:00:11.136000000
Language: qad
Mime:
audio/x-eac3, channels=(int)6, rate=(int)48000, bitrate=(int)999
------------------------
------------------------
Track 17 [video_0] Enabled
Duration: 0:00:12.158356000
Language: und
Mime:
video/x-h264, parsed=(boolean)true, alignment=(string)au, stream-format=(string)byte-stream, width=(int)1920, height=(int)1088, framerate=(fraction)25/1
------------------------
====== VPUDEC: 4.3.5 build on Jan 21 2019 17:47:26. ======
wrapper: 3.0.0 (VPUWRAPPER_ARM64_LINUX Build on Jan 21 2019 17:02:05)
vpulib: 1.1.1
firmware: 1.1.1.65535
ERROR: h264bsdDecodeSeiParameters error

Redistribute latency...
ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstAudioSinkClock
ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

ERROR: h264bsdDecodeSeiParameters error

.

.

.

0 Kudos

163 Views
joanxie
NXP TechSupport
NXP TechSupport

I played out.ts on the PC, I found mosaic in the first one second, and then I played on the board with gplay-1.0 out.ts, and I got the same error, but I can see the video on the display successfully, so I suggest that you can test another ts file, I'm not sure if there is something wrong with your ts file, and the error message doesn't affect playing this ts file

0 Kudos

163 Views
fredericduchass
Contributor III

Hello Joan,

You're right the display is not affected by this message. All seems decoded perfectly.

But this message should not be very safe.

This is another TS files with the same error :

https://wetransfer.com/downloads/0272b72f7f96205ad8271d332cf5738920190130082423/83359a9b86d9f64dbaa3...

I have many other which gives same error because it's french terrestrial TV.

0 Kudos