IMX8M WoWLAN(Wake on WIFI) from Low power mode(Ideal DDR167MHz) and USB wake-up disable

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

IMX8M WoWLAN(Wake on WIFI) from Low power mode(Ideal DDR167MHz) and USB wake-up disable

1,508 Views
venkateshp54
Contributor I

Dear Team,

I am using IMX8M Eval board,One of my use case I need to wake-up this system from WIFI WoWLAN (USB-WIFI dongle).

I am putting system into low power mode(IDEAL DDR-167MHz mode):

--------------------------------------

Scenario 1:USB-WIFI Dongle not connected

--------------------------------------

By using the below command i am putting system into Low Power Ideal DDR-167MHz mode

echo 8 > /proc/sys/kernel/printk
ifconfig eth0 down

------

logs:

------
root@imx8mqevk:~# echo 8 > /proc/sys/kernel/printk
root@imx8mqevk:~# ifconfig eth0 down
root@imx8mqevk:~# [ 1062.530382] ddrc freq set to low bus mode
[ 1066.595008] ddrc freq set to high bus mode
[ 1067.682375] ddrc freq set to low bus mode
[ 1071.714999] ddrc freq set to high bus mode
[ 1072.802368] ddrc freq set to low bus mode
ddrc freq set to low bus modeddrc freq set to low bus mode^C
root@imx8mqevk:~#

------

USB-Dongle Connecting Time

------ 

logs:

root@imx8mqevk:~# [ 3915.105985] ddrc freq set to high bus mode
[ 3915.345587] usb 1-1: new high-speed USB device number 3 using xhci-hcd
[ 3915.500269] RTL871X:
[ 3915.500269] usb_endpoint_descriptor(0):
[ 3915.506447] RTL871X: bLength=7
[ 3915.509574] RTL871X: bDescriptorType=5
[ 3915.513386] RTL871X: bEndpointAddress=81
[ 3915.517370] RTL871X: wMaxPacketSize=512
[ 3915.521320] RTL871X: bInterval=0
[ 3915.524548] RTL871X: RT_usb_endpoint_is_bulk_in = 1
[ 3915.529488] RTL871X:
[ 3915.529488] usb_endpoint_descriptor(1):
[ 3915.535699] RTL871X: bLength=7
[ 3915.538816] RTL871X: bDescriptorType=5
[ 3915.542678] RTL871X: bEndpointAddress=2
[ 3915.546576] RTL871X: wMaxPacketSize=512
[ 3915.550528] RTL871X: bInterval=0
[ 3915.553818] RTL871X: RT_usb_endpoint_is_bulk_out = 2

root@imx8mqevk:~#

---------------

USB-Dongle Removal Time

--------------- 

logs:

root@imx8mqevk:~#
root@imx8mqevk:~# [ 4411.198204] usb 1-1: USB disconnect, device number 3
[ 4411.203523] RTL871X: +rtw_dev_remove
[ 4411.207777] RTL871X: cfg80211_rtw_get_txpower
[ 4411.225111] RTL871X: rtw_ndev_uninit(wlan0)
[ 4411.257099] RTL871X: rtw_wdev_unregister(wdev=ffff8000b9e2d800)
[ 4411.263113] RTL871X: Vendor: Unregister RTW cfg80211 vendor interface
[ 4411.293789] RTL871X: rtw_pm_set_ips IPS_NONE
[ 4411.298092] RTL871X: LeaveAllPowerSaveMode(wlan0): bup=0 Skip!
[ 4411.304007] RTL871X: LeaveAllPowerSaveMode(wlan0): bup=0 Skip!
[ 4411.309926] RTL871X: ### Clean STA_(1) info ###
[ 4411.314589] RTL871X: rtw_dev_unload: bup==_FALSE
[ 4411.319276] RTL871X: +r871xu_dev_remove, hw_init_completed=0
[ 4411.325066] RTL871X: rtw_wdev_free(wdev=ffff8000b9e2d800)
[ 4411.330952] RTL871X: 4free_recv_skb_queue not empty, 8
[ 4411.336372] RTL871X: -r871xu_dev_remove, done
[ 4412.514410] ddrc freq set to low bus mode

--------------------------------------

--------------------------------------

Scenario 2:USB-WIFI Dongle connected and System it's not going to the Ideal Mode

--------------------------------------

echo 8 > /proc/sys/kernel/printk
ifconfig eth0 down

Observation:

* If USB-dongle  is not connected system was going to Ideal Mode properly, When ever i am going to connect this USB-dongle system state changes from Ideal mode to Normal mode.

*If USB-dongle connected system it's not going to the Ideal mode.

1.How to disable the USB-Wake up option in the IMX8M side?

2.Is it possible  wifi wake-up this system from Ideal mode to Normal mode by using other system?

Thanks,

Venkatesh

0 Kudos
1 Reply

1,148 Views
igorpadykov
NXP Employee
NXP Employee

Hi Venkatesh

1. one can check sect.4.9.7 USB Wakeup Usage attached Linux Manual

2. any enabled interrupt can wake processor from low power mode, so for example

if wifi has gpio, it can wake processor with gpio.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos