IMX8M Mini with X11 and Etnaviv

cancel
Showing results for 
Search instead for 
Did you mean: 

IMX8M Mini with X11 and Etnaviv

301 Views
arslan
Contributor III

Hi all,

I am working wit IMX8M Mini EVKB Board. My requirement from customer is, building a distribution with Yocto, which includes Chromium. Their main requirement is, that chromium browser should achive at least 40 points in MotionMark Test at https://browserbench.org/

Under xwayland with Vivanter drivers chromium is not accelerated at all, so that we achive 2-3 points. 

Under Xorg with KMS we achive ~31 points. 

I already compiled the kernel modules for etnaviv and xorg has the libs etnaviv_dri.so and Mesa.

I am not sure if etnaviv is used or correctly configured at all. 

I am using yocto hardknott with kernel 5.10, etnaviv kernel driver seems to be loaded correctly, my xorg configuration has not much:

Section "Device"
    Identifier "etnaviv"
    Driver     "modesetting"
    Option     "kmsdev"      "/dev/dri/card1"
    Option     "AccelMethod" "glamor"
    Option     "Atomic"      "On"
EndSection

Section "ServerFlags"
    Option     "AutoAddGPU"  "false"
    Option     "DRI"         "3"
EndSection

 

This is all I have in conf file. Wenn I run glxgears or chromium, these applications run, but it seems to be not using Hw-acceleration or OpenGL, here are some output from these applications:

libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libEGL warning: DRI2: failed to create dri screen

 

Did anyone get chromium accelerated under IMXM Mini at all. Or, integrated in etnaviv and Xorg succesfully?

 

0 Kudos
7 Replies

237 Views
arslan
Contributor III

Thanks for your replies,

I think, I need to explain my problem deeper and make it more clear:

I don't have a problem with video rendering in chromium, at least not yet. Our project has already other more basic problems. Main problem is, that Canvas and Compositing is software rendered, OpenGL and WebGL is not available.

What I did:

I built the yocto image from fsl community bsp. DISTRO: fslc-x11, MACHINE: imx8mm-lpddr4-evk

I activated etnaviv and galcore. The reason, I am using X11 is, according to i.MX Yocto Project User's Guide (Rev. LF5.10.52_2.1.0 — 30 September 2021), X11 is not supported by Vivante. Building chromium ozone for wayland seems to be broken, I am always getting the error:

 

 

| Package dri was not found in the pkg-config search path.
| Perhaps you should add the directory containing `dri.pc'
| to the PKG_CONFIG_PATH environment variable
| No package 'dri' found

 

 


According to suggested workarounds, we should just add "mesa" to chromium-ozone-wayland DEPENDS, but this did not do anything. It still fails.

For xwayland, I could build chromium (chromium ozone), but the performance was veeery poor, despite the vivante drivers were used. I got about 2-4 scoring in browserbench.org.

At least, in X11 I am getting scores about 30-34.

This is the output of the page chrome://gpu from this case.

 

 

Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
Compositing: Software only. Hardware acceleration disabled
Multiple Raster Threads: Enabled
Out-of-process Rasterization: Hardware accelerated
OpenGL: Unavailable
Rasterization: Hardware accelerated on all pages
Skia Renderer: Enabled
Video Decode: Software only. Hardware acceleration disabled
Vulkan: Disabled
WebGL: Unavailable
WebGL2: Unavailable
Driver Bug Workarounds
clear_uniforms_before_first_program_use
count_all_in_varyings_packing
exit_on_context_lost
scalarize_vec_and_mat_constructor_args
disabled_extension_GL_KHR_blend_equation_advanced
disabled_extension_GL_KHR_blend_equation_advanced_coherent

Problems Detected
GL driver is software rendered. GPU acceleration is disabled: 59302, 315217, 1155974
Disabled Features: accelerated_webgl2, android_surface_control, gpu_rasterization, accelerated_gl, metal, accelerated_2d_canvas, oop_rasterization, accelerated_video_decode, accelerated_webgl, vulkan

 

 

On kernel logs, I see etnaviv is loaded succesfully. Besides this I have no indication of properly configured/loaded/working etnaviv under Xorg.

This the output on xterm:

sh-5.1# glxgears
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
246 frames in 5.0 seconds = 49.181 FPS
240 frames in 5.0 seconds = 47.894 FPS
^C
sh-5.1# chromium --no-sandbox --enable-accelerated-2d-canvas --enable-gpu-rasterization --enable-features=VizDisplayCompositor --enable-gpu-compositing --window-size=1200,900 --ignore-gpu-blacklist --enable-zero-copy --enable-native-gpu-memory-buffers
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
[619:619:0309/123741.753063:ERROR:browser_dm_token_storage_linux.cc(94)] Error: /etc/machine-id contains 0 characters (32 were expected).
libEGL warning: DRI2: failed to create dri screen
libEGL warning: DRI2: failed to create dri screen
[619:650:0309/123745.716596:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123745.716835:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123747.237437:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123747.237580:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:698:0309/123750.433587:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[619:698:0309/123750.479565:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.GetDisplayDevice: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[619:698:0309/123750.562722:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.EnumerateDevices: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
sh-5.1#

Has anyone successfully used etnaviv under X11/Xorg ?

Or

Has anyone succesfully configured and built chromium with working hardware acceleration for WegGl, OpenGL, rasterization... for IMX8M Mini under Wayland/XWayland...?

@Bio_TICFSL Is there a working recipe for Chromium under wayland, or any reports, that someone has successfully used chromium under imx8mm mini with hardware accelerated ? Most importantly for the following points:

  • Canvas
  • Rasterization
  • WebGL/2

Hardware accelerated video under chromium is not my priority.

 

Thanks for the support

0 Kudos

254 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello Arslan,

 

X11 and etnaviv are not supported by MX8MMini, and Chromium does not directly call VPU hardware decoders, but gstreamer can do it, so gplay can play video smoothly.

So you can use Chromium  on GStreamer project to realize your purpose.

Here is the git hub project:

https://github.com/Samsung/ChromiumGStreamerBackend

Hope this information can help you!

Regards

0 Kudos

236 Views
arslan
Contributor III

Hello Kunyichen,

Thanks for the reply. 

I think, I could not explain the problem very precisely, I might also have a problem with accelerated videos, but I am very far away from that point yet. 

 

First, I am trying to get Chromium with accelerated features. Currently chromium tells me the following info when I go to the page chrome://gpu

arslan_0-1633268646302.png

As we can see here, Canvas and Compositing features are software only, OpenGL seems to be disabled completely.

According to the information in i.MX Yocto Project User's Guide (Rev. LF5.10.52_2.1.0 — 30 September 2021):

  • X11 is only supperted from fsl-community.
  • Xwayland is possible but X11 applications are not accelerated.

My attempt to build Chromium failed with an error

| Package dri was not found in the pkg-config search path.
| Perhaps you should add the directory containing `dri.pc'
| to the PKG_CONFIG_PATH environment variable
| No package 'dri' found

A search to fix the problem,tells to add "mesa" as DEPENDS to chromium-ozone recipe. Doing that did not change anything with the problem, I still cannot build chromium for wayland. 

For xwayland I was abel to build but it not accelerated and the score I get from browserbench.org is ~3

The only promising results I got, come from fslc-x11 DISTRO from community. Here we score about 30, the above image from chrome://gpu shows this configuration. 

In this configuration, the output:

sh-5.1# glxgears
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
246 frames in 5.0 seconds = 49.181 FPS
240 frames in 5.0 seconds = 47.894 FPS
^C
sh-5.1# chromium --no-sandbox --enable-accelerated-2d-canvas --enable-gpu-rasterization --enable-features=VizDisplayCompositor --enable-gpu-compositing --window-size=1200,900 --ignore-gpu-blacklist --enable-zero-copy --enable-native-gpu-memory-buffers
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
[619:619:0309/123741.753063:ERROR:browser_dm_token_storage_linux.cc(94)] Error: /etc/machine-id contains 0 characters (32 were expected).
libEGL warning: DRI2: failed to create dri screen
libEGL warning: DRI2: failed to create dri screen
[619:650:0309/123745.716596:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123745.716835:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123747.237437:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123747.237580:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:698:0309/123750.433587:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[619:698:0309/123750.479565:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.GetDisplayDevice: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[619:698:0309/123750.562722:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.EnumerateDevices: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
sh-5.1#

These are the outputs from glxgears and chromium. 

Besides this:

How do I know that etnaviv on kernel side is configured and used correctly?

How can I check on X11 side, that etnaviv is used?

Did anyone successfuly used etnaviv with imx8M mini?

0 Kudos

294 Views
kunyichen
Contributor IV

maybe to check your chromium build with GPU hardware accelecer enabled (check EGL enabled) and if you need video hardware decode need patch something for enabled VA-API

ref. https://forum.manjaro.org/t/howto-enable-hardware-video-acceleration-video-decode-in-google-chrome-b...

 

0 Kudos

238 Views
arslan
Contributor III

Hello Kunyichen,

 

Thanks for your reply. I think, I need to explain my problem deeper and make it more clear:

I don't have a problem with video rendering in chromium, at least not yet. Our project has already other more basic problems. Main problem is, that Canvas and Compositing is software rendered, OpenGL and WebGL is not available.

What I did:

I built the yocto image from fsl community bsp. DISTRO: fslc-x11, MACHINE: imx8mm-lpddr4-evk

I activated etnaviv and galcore. The reason, I am using X11 is, according to i.MX Yocto Project User's Guide (Rev. LF5.10.52_2.1.0 — 30 September 2021), X11 is not supported by Vivante. Building chromium ozone for wayland seems to be broken, I am always getting the error:

 

| Package dri was not found in the pkg-config search path.
| Perhaps you should add the directory containing `dri.pc'
| to the PKG_CONFIG_PATH environment variable
| No package 'dri' found

 

 According to suggested workarounds, we should just add "mesa" to chromium-ozone-wayland DEPENDS, but this did not do anything. It still fails. 

For xwayland, I could build chromium, but the performance was veeery poor. I got about 2-4 scoring in browserbench.org.

At least, in X11 I am getting scores about 30-34. 

arslan_0-1633287079954.png

This is the page chrome://gpu from this case.

On kernel logs, I see etnaviv is loaded succesfully. Besides this I have no indication of properly configured/loaded/working etnaviv under Xorg.

This the output on xterm:

 

sh-5.1# glxgears
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
246 frames in 5.0 seconds = 49.181 FPS
240 frames in 5.0 seconds = 47.894 FPS
^C
sh-5.1# chromium --no-sandbox --enable-accelerated-2d-canvas --enable-gpu-rasterization --enable-features=VizDisplayCompositor --enable-gpu-compositing --window-size=1200,900 --ignore-gpu-blacklist --enable-zero-copy --enable-native-gpu-memory-buffers
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
[619:619:0309/123741.753063:ERROR:browser_dm_token_storage_linux.cc(94)] Error: /etc/machine-id contains 0 characters (32 were expected).
libEGL warning: DRI2: failed to create dri screen
libEGL warning: DRI2: failed to create dri screen
[619:650:0309/123745.716596:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123745.716835:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123747.237437:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123747.237580:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:698:0309/123750.433587:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[619:698:0309/123750.479565:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.GetDisplayDevice: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[619:698:0309/123750.562722:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.EnumerateDevices: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
sh-5.1#

 

 

Has anyone successfully used etnaviv under X11/Xorg ?

Or 

Has anyone succesfully configured and built chromium with working hardware acceleration for WegGl, OpenGL, rasterization... for IMX8M Mini under Wayland/XWayland...?

0 Kudos

238 Views
arslan
Contributor III

Hello Kunyichen,

 

Thanks for your reply. I think, I need to explain my problem deeper and make it more clear:

I don't have a problem with video rendering in chromium, at least not yet. Our project has already other more basic problems. Main problem is, that Canvas and Compositing is software rendered, OpenGL and WebGL is not available.

What I did:

I built the yocto image from fsl community bsp. DISTRO: fslc-x11, MACHINE: imx8mm-lpddr4-evk

I activated etnaviv and galcore. The reason, I am using X11 is, according to i.MX Yocto Project User's Guide (Rev. LF5.10.52_2.1.0 — 30 September 2021), X11 is not supported by Vivante. Building chromium ozone for wayland seems to be broken, I am always getting the error:

| Package dri was not found in the pkg-config search path.
| Perhaps you should add the directory containing `dri.pc'
| to the PKG_CONFIG_PATH environment variable
| No package 'dri' found

 According to suggested workarounds, we should just add "mesa" to chromium-ozone-wayland DEPENDS, but this did not do anything. It still fails. 

For xwayland, I could build chromium, but the performance was veeery poor. I got about 2-4 scoring in browserbench.org.

At least, in X11 I am getting scores about 30-34. 

arslan_0-1633287079954.png

This is the page chrome://gpu from this case.

On kernel logs, I see etnaviv is loaded succesfully. Besides this I have no indication of properly configured/loaded/working etnaviv under Xorg.

This the output on xterm:

sh-5.1# glxgears
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
246 frames in 5.0 seconds = 49.181 FPS
240 frames in 5.0 seconds = 47.894 FPS
^C
sh-5.1# chromium --no-sandbox --enable-accelerated-2d-canvas --enable-gpu-rasterization --enable-features=VizDisplayCompositor --enable-gpu-compositing --window-size=1200,900 --ignore-gpu-blacklist --enable-zero-copy --enable-native-gpu-memory-buffers
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
[619:619:0309/123741.753063:ERROR:browser_dm_token_storage_linux.cc(94)] Error: /etc/machine-id contains 0 characters (32 were expected).
libEGL warning: DRI2: failed to create dri screen
libEGL warning: DRI2: failed to create dri screen
[619:650:0309/123745.716596:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123745.716835:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123747.237437:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123747.237580:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:698:0309/123750.433587:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[619:698:0309/123750.479565:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.GetDisplayDevice: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[619:698:0309/123750.562722:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.EnumerateDevices: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
sh-5.1#

 

Has anyone successfully used etnaviv under X11/Xorg ?

Or 

Has anyone succesfully configured and built chromium with working hardware acceleration for WegGl, OpenGL, rasterization... for IMX8M Mini under Wayland/XWayland...?

0 Kudos

237 Views
arslan
Contributor III

Hello Kunyichen,

 

Thanks for your reply. I think, I need to explain my problem deeper and make it more clear:

I don't have a problem with video rendering in chromium, at least not yet. Our project has already other more basic problems. Main problem is, that Canvas and Compositing is software rendered, OpenGL and WebGL is not available.

What I did:

I built the yocto image from fsl community bsp. DISTRO: fslc-x11, MACHINE: imx8mm-lpddr4-evk

I activated etnaviv and galcore. The reason, I am using X11 is, according to i.MX Yocto Project User's Guide (Rev. LF5.10.52_2.1.0 — 30 September 2021), X11 is not supported by Vivante. Building chromium ozone for wayland seems to be broken, I am always getting the error:

| Package dri was not found in the pkg-config search path.
| Perhaps you should add the directory containing `dri.pc'
| to the PKG_CONFIG_PATH environment variable
| No package 'dri' found

 According to suggested workarounds, we should just add "mesa" to chromium-ozone-wayland DEPENDS, but this did not do anything. It still fails. 

For xwayland, I could build chromium, but the performance was veeery poor. I got about 2-4 scoring in browserbench.org.

At least, in X11 I am getting scores about 30-34. 

arslan_0-1633287079954.png

This is the page chrome://gpu from this case.

On kernel logs, I see etnaviv is loaded succesfully. Besides this I have no indication of properly configured/loaded/working etnaviv under Xorg.

This the output on xterm:

sh-5.1# glxgears
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
246 frames in 5.0 seconds = 49.181 FPS
240 frames in 5.0 seconds = 47.894 FPS
^C
sh-5.1# chromium --no-sandbox --enable-accelerated-2d-canvas --enable-gpu-rasterization --enable-features=VizDisplayCompositor --enable-gpu-compositing --window-size=1200,900 --ignore-gpu-blacklist --enable-zero-copy --enable-native-gpu-memory-buffers
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
libGL error: failed to create dri screen
libGL error: failed to load driver: imx-drm
[619:619:0309/123741.753063:ERROR:browser_dm_token_storage_linux.cc(94)] Error: /etc/machine-id contains 0 characters (32 were expected).
libEGL warning: DRI2: failed to create dri screen
libEGL warning: DRI2: failed to create dri screen
[619:650:0309/123745.716596:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123745.716835:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123747.237437:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:650:0309/123747.237580:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[619:698:0309/123750.433587:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[619:698:0309/123750.479565:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.GetDisplayDevice: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[619:698:0309/123750.562722:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.EnumerateDevices: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
sh-5.1#

 

Has anyone successfully used etnaviv under X11/Xorg ?

Or 

Has anyone succesfully configured and built chromium with working hardware acceleration for WegGl, OpenGL, rasterization... for IMX8M Mini under Wayland/XWayland...?

0 Kudos