IMX8 gst-discoverer-1.0 // uridecodebin not working with some contents

cancel
Showing results for 
Search instead for 
Did you mean: 

IMX8 gst-discoverer-1.0 // uridecodebin not working with some contents

385 Views
kamkam
Contributor I

Hi all,

I'm using an image from Toradex with gstreamer package from NXP.

No additional features from Toradex and gstreamer version is 1.16.2n the current one in NXP.

I'm using gst-discoverer-1.0 (which  calls uridecodebin underlying...), and with some MKV contents, it does not work...and gst-discoverer-1.0 returns with a timeout error.

Whereas all of these contents are working fine with gstreamer 1.16 on every other platforms (windows, Linux boxes etc).

No problem of firewall on my side.

For example, for IMX8, the gstreamer gst-discoverer-1.0 does not work:

 

gst-discoverer-1.0 http://fmr-dev.net/tmp/the_100.mkv

 

It works on every other platforms.

Any idea ? It's a really blocking issue on our side.

 

Thanks.

 

kam

Tags (1)
0 Kudos
4 Replies

352 Views
joanxie
NXP TechSupport
NXP TechSupport

what imx8 board do you use and what bsp version do you mention?

0 Kudos

342 Views
kamkam
Contributor I

Hello Joanxie,

 

I have tested on the platforms below:

 

  1. Apalis IMX8 bsp 5.2.0
  2. Colibri IMX8X bsp 5.3.0

 

It failed on both.

0 Kudos

276 Views
joanxie
NXP TechSupport
NXP TechSupport

did you get any error message when you use "gst-discoverer-1.0"? I tested it on the nxp board, I didn't find any issue with gst-discoverer-1.0 command, this is my test result as below:

"root@imx8qxpc0mek:~# gst-discoverer-1.0 --gst-version
GStreamer Core Library version 1.18.0"

0 Kudos

348 Views
zyend
Contributor II

I'm experiencing the same issue than kamkam.

 

 

0 Kudos