IMX6ULL SD card not booting in our customised board

cancel
Showing results for 
Search instead for 
Did you mean: 

IMX6ULL SD card not booting in our customised board

1,583 Views
ramesh6663
Contributor III

Hi,

We are in hardware board bringup stage in customised IMX6ULL board. We used IMX6ULL NXP EVK uboot Image just for our checking purpose of board is booting or not form SD boot. But board is not booting so I have checked boot config logic level boot mode and switch respectively all are fine in hardware. so following are the Queries I have.

1. NXP EVK used processor serial number over the IC is " MCIMX6Y2DVM05AA  CTAB1643 0N70S CHINA FQABCTH" , Our board has "MCIMX6Y2DVM05AA  CTAK1718 0N70S CHINA GRAKCTP". Differences are highlighted in blue colour. If this difference has any errata has causing SD boot issue or in software we need to change any register setting etc..? Please provide us the information about blue coloured series number.

2. what is the maximum density of uSD card can be used in IMX6ULL and I hope all uSD card manufacturers cards will support?

3.If except JTAG is there any other ways to find out the SD card boot issue?

4. Is it any possibilities in software end that cause the SD boot issue when hardware end everything was fine?

Thanks & Regards,

Rameshkumar

Labels (1)
Tags (2)
0 Kudos
7 Replies

512 Views
ramesh6663
Contributor III

Hi Yuri,

     We tried all your suggestion, but still board is not booting.

we tried putting the uboot.imx and kernel image to the ram directly using the mfgtool provided by nxp. , it is hanging at the "starting kernel ...." no log is coming further .

NXP EVK used processor serial number over the IC is " MCIMX6Y2DVM05AA  CTAB1643 0N70S CHINA FQABCTH" , Our board has "MCIMX6Y2DVM05AA  CTAK1718 0N70S CHINA GRAKCTP". Differences are highlighted in blue colour Is it cause any issue in SD card boot up?

Thanks 

Ramesh

0 Kudos

512 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

   No problems with the i.MX6ULL parts, if they are provided by NXP distributors.

Regards,

Yuri.

0 Kudos

512 Views
ramesh6663
Contributor III

Thanks Yuri,

  

Could your please give us your feedback on this?

    We tried all your suggestion, but still board is not booting.

we tried putting the uboot.imx and kernel image to the ram directly using the mfgtool provided by nxp. , it is hanging at the "starting kernel ...." no log is coming further .

Thanks.

Ramesh

0 Kudos

512 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

   Please try the following demo BSP for i.MX6ULL

http://www.nxp.com/webapp/Download?colCode=L4.1.15_2.0.1_iMX6ULL&appType=license&location=null&Paren... 

or the following

http://www.nxp.com/webapp/Download?colCode=L4.1.15_2.0.0_iMX6ULL&appType=license&location=null&Paren...  

on NXP 6ULL EVK first, a after that on Your board.

   If the demo BSP are / is working but Yours - does not, please check and compare carefully board

configurations and schematics of both boards.  

Regards,

Yuri.

0 Kudos

512 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

   Please try to run the DDR Stress Test right after SD boot crash; do not touch settings,

do not reset. The i.MX6 boot ROM after SD boot crash should be in serial downloader mode,

allowing to load and run the Stress Test. It provides boot config (from SRC Boot Mode Register 1),

when run. Please check if the boot configuration is correct.

https://community.nxp.com/docs/DOC-105652 

Have a great day,
Yuri

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

512 Views
ramesh6663
Contributor III

Hi Yuri Muhin, 

DDR3 Stress test is successful and our Boot configuration is correct I checked. Power up sequence also fine. But still we didn't get any serial print in the console. Using MFG tool we try to flash the uboot image but we cant able to get " UTP".  Please see the below serial print which we got when try USBOTG - MFG tool.

Below is uboot and kernel logs

************************************************************************ 

U-Boot 2016.03-imx_v2016.03_4.1.15_2.0.3+g0ec2a01 (Mar 15 2017 - 06:04:34 -0500)

 

CPU:   Freescale i.MX6ULL rev1.0 528 MHz (running at 396 MHz)

CPU:   Commercial temperature grade (0C to 95C) at 44C

Reset cause: POR

Board: MX6ULL 14x14 EVK

I2C:   ready

DRAM:  512 MiB

MMC:   FSL_SDHC: 0, FSL_SDHC: 1

*** Warning - bad CRC, using default environment

 

Display: TFT43AB (480x272)

Video: 480x272x24

In:    serial

Out:   serial

Err:   serial

MMC: no card present

Net:   Board Net Initialization Failed

No ethernet found.

Boot from USB for mfgtools

Use default environment for mfgtools

Run bootcmd_mfg: run mfgtool_args;bootz ${loadaddr} ${initrd_addr} ${fdt_addr};

Hit any key to stop autoboot:  0

Kernel image @ 0x80800000 [ 0x000000 - 0x554130 ]

## Loading init Ramdisk from Legacy Image at 83800000 ...

   Image Name:   fsl-image-mfgtool-initramfs-imx6

   Image Type:   ARM Linux RAMDisk Image (gzip compressed)

   Data Size:    8591032 Bytes = 8.2 MiB

   Load Address: 00000000

   Entry Point:  00000000

   Verifying Checksum ... OK

## Flattened Device Tree blob at 83000000

   Booting using the fdt blob at 0x83000000

   Using Device Tree in place at 83000000, end 8300c93c

Modify /soc/aips-bus@02200000/epdc@0228c000:status disabled

ft_system_setup for mx6

 

Starting kernel ...

Thanks & Regards,

Rameshkumar

0 Kudos