IMX6UL is not recognised as HID compliant

cancel
Showing results for 
Search instead for 
Did you mean: 

IMX6UL is not recognised as HID compliant

848 Views
dawn
Contributor I

My Grinn liteboard uses i.MX6UL processor, and I am using Buildroot. I can get boot my board with my images through the use of a uSD card. But I want to use MFG Tool to transfer my images to my board so that I can boot my board without having to burn my images to a uSD card. I don't want to have to use the uSD card. As far as my research has shown, my board needs to be detected as a HID compliant device in order to do the transfer without uSD card using MFG Tool (and even if I follow tutorial Guide to flash iMX6 from Linux to use Linux to achieve what MFG Tool does). However, I have tried many ways to do so, but my board only shows up as a com port (COM3). There is no "HID conform, from producer defined Device" driver either for me to install so that my board shows up as HID compliant. I have already changed my boot mode to Serial Downloader mode, but I cannot figure out what is wrong.

Anybody face a similar issue? Am I missing some set up configuration? Or is there any way for me to transfer my OS image to my board directly to boot so I do not need a uSD card in order to boot? Can anyone point me in the right direction?

Edit: I have tried imx-3.14.38_6UL_ga_mfg-tools and the latest L4.1.15_2.0.0-ga_mfg-tools, both of which end up with MfgTool2.exe just opening up telling me No Device Connected. My Device Manager detects my board only as a COM port. I am using Windows 10, but I have tried Windows 7 on VirtualBox, which also shows No Device Connected when I run MfgTool2.exe. I cannot figure out what I am missing?? All I want is to be able to transfer my OS to the board without a uSD card.

Labels (3)
0 Kudos
1 Reply

293 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Dawn,

I’m not familiar with the Grinn Lite Board. Hopefully more community users can share the experience with this board. I wasn’t aware of the

The steps you mention look correct, setting the Serial Downloader mode etc. However, it sounds like perhaps you are using the wrong USB port since it continues to be detected as a COM port (either that or maybe there’s a problem with the drivers and it’s not using the default HID driver, in that case you could try uninstalling the driver and letting it reinstall by plugging the USB cable again). I’m not familiar with the board so maybe it just has one possible USB for the Serial Downloader but I wanted to mention it so you could double check.

Also, I’m not sure if this board has Manufacturing Tool support so it would be good to double check with the manufacturer.

There is a document on how to program the eMMC booting from an SD card first. Perhaps this could also be an alternative for you.

http://wiki.litesom.grinn-global.com/index.php?title=How_to_program_eMMC

I hope this helps!

Regards,

0 Kudos