IMX6Q+PF100 PMIC reboot failed using hw wdog2

cancel
Showing results for 
Search instead for 
Did you mean: 

IMX6Q+PF100 PMIC reboot failed using hw wdog2

526 Views
mayqueen
Contributor IV

Hello All:


OS: Android 7.1
CPU: IMX6Q/D

I refer Sabresd board and design a new board, but I have a big issue now: cannot reboot system, it will hangs before start u-boot.

For the hardware part:
1. I almost copy from sabresd board for PMIC relative circuit including power button, and the wdog2 pin also the same - GPIO_1, but when I issue reboot command, I observe the behavior using scope, the wdog2 is really pull lo and hi once but hardware has no any reset action...
I doubt maybe I use 2 5V regulators and 1 3.3V regulator from CPU
NANDF_CLE, NANDF_WP_B, and NANDF_RB0, maybe I need to pull lo first before reboot? but it doesn't make sense..

For the software part:
1. my dts is also follow sabresd:
linux-imx/imx6qdl-pistachio.dtsi at nutsboard_nxp_4.1.15_2.0.0_ga · nutsboard/linux-imx · GitHub 
maybe the gpc need to set ldo-bypass=0, but I also tried, and I also use gateworks patch to modify arch/arm/mach-imx/imx2-wdt.c, but still hangs...

2. because I have no more money to make a new board, I have a workaround way to force do soft reset only, and I refer this patch:
[RFC] imx6: Fix reboot routine for boards using WDOG2 as reset. 

it works but sometime still reboot hang or "random hangs when reboot success (hangs on u-boot always)", I loss some keys?

hope somebody can give me some comments, I don't want to my customers disappoint for this issue...

Thank you so much!



Labels (3)
2 Replies

115 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi May

wdog should reset all board power as it is done on i.MX6Q SabreSD

spf-27392 schematic p.21 U507 and pmic PWRON signal. I am afraid there is

no reliable software way, as after reset processor boot with ldo enabled mode.

Android low power driver may low voltages below allowable limit for reliable boot.

So just before reboot one can try to disable any frequency(power voltages) changes.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

115 Views
mayqueen
Contributor IV

Thank you, I already fixed it, just add ldo_active=on in cmdline and disabling the wdog2, about the dts setting, I refer from sabresd-ldo.dts, thanks for your help.

0 Kudos