IMX6 dual core : Lvds clock gets reduce when enable HDMI blanking (trying to enable clone mode))

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

IMX6 dual core : Lvds clock gets reduce when enable HDMI blanking (trying to enable clone mode))

204件の閲覧回数
yogeshbsa89
Contributor II

Hi Community,

 I am seeing flickering in LVDS display when we enable HDMI blanking (trying to clone) in QMX6 dual core based SOC.

This issue we are seeing with LVDS with resolution 1024X600  ( minor flickering) and 1280X800  (More flickering).

But there is no issues with Low resolution 800X480.

After Probing the LVDS clock we observed that clock of LVDS is reduced to approx. 20 MHz when we enable HDMI blanking.

Clock reduction is only happening with higher resolution  LVDS display not with 800X480 resolution.

Yocto Linux  - 5.4.3

device tree configuration : 

hdmi_core@120000 {
compatible = "fsl,imx6q-hdmi-core";
reg = <0x120000 0x9000>;
clocks = <0x4 0x7c 0x4 0x7b 0x4 0x8a>;
clock-names = "hdmi_isfr", "hdmi_iahb", "mipi_core";
status = "okay";
ipu_id = <0x0>;
disp_id = <0x0>;
};

hdmi_video@20e0000 {
compatible = "fsl,imx6q-hdmi-video";
reg = <0x20e0000 0x1000>;
reg-names = "hdmi_gpr";
interrupts = <0x0 0x73 0x4>;
clocks = <0x4 0x7c 0x4 0x7b 0x4 0x8a>;
clock-names = "hdmi_isfr", "hdmi_iahb", "mipi_core";
status = "okay";
fsl,phy_reg_vlev = <0x1ef>;
fsl,phy_reg_cksymtx = <0x800b>;
HDMI-supply = <0x15>;
};

 

ldb {
#address-cells = <0x1>;
#size-cells = <0x0>;
compatible = "fsl,imx6q-ldb", "fsl,imx53-ldb";
gpr = <0x5>;
status = "okay";
clocks = <0x4 0x87 0x4 0x88 0x4 0x27 0x4 0x28 0x4 0x29 0x4 0x2a 0x4 0xb8 0x4 0xb9 0x4 0x10b 0x4 0x10c 0x4 0x10d 0x4 0x10e>;
clock-names = "ldb_di0", "ldb_di1", "di0_sel", "di1_sel", "di2_sel", "di3_sel", "ldb_di0_div_3_5", "ldb_di1_div_3_5", "ldb_di0_div_7", "ldb_di1_div_7", "ldb_di0_div_sel", "ldb_di1_div_sel";

lvds-channel@0 {
#address-cells = <0x1>;
#size-cells = <0x0>;
reg = <0x0>;
status = "okay";
fsl,data-mapping = "jeida";
fsl,data-width = <0x18>;
primary;
crtc = "ipu2-di0";

port@0 {
reg = <0x0>;

endpoint {
remote-endpoint = <0x6>;
phandle = <0x52>;
};
};

port@1 {
reg = <0x1>;

endpoint {
remote-endpoint = <0x7>;
phandle = <0x56>;
};
};

port@2 {
reg = <0x2>;

endpoint {
remote-endpoint = <0x8>;
phandle = <0x5c>;
};
};

port@3 {
reg = <0x3>;

endpoint {
remote-endpoint = <0x9>;
phandle = <0x60>;
};
};

display-timings {
native-mode = <0xa>;

hsd100pxn1 {
clock-frequency = <0x208E600>; //0xD05C0// <0x208E600>;//40 frames in a second.
hactive = <0x400>;
vactive = <0x258>;
hfront-porch = <0x96>;
hsync-len = <0x14>;
hback-porch = <0x96>;
vfront-porch = <0xf>;
vsync-len = <0x5>;
vback-porch = <0xf>;
hsync-active = <0x0>;
vsync-active = <0x0>;
pixelclk-active = <0x1>;


};
};
};

Please suggest changes in clock  / IPU configuration to fix clock reduction problem.

 

 

ラベル(4)
0 件の賞賛
1 返信

186件の閲覧回数
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello

I can not reproduce the issue, since you are playing with a non-supported kernel its maybe the problem here, you can download the official kernel and BSP from:

https://www.nxp.com/design/software/embedded-software/i-mx-software/embedded-linux-for-i-mx-applicat...

 

Regards

0 件の賞賛