IMX PCIe port: link down! with atheros pcie

cancel
Showing results for 
Search instead for 
Did you mean: 

IMX PCIe port: link down! with atheros pcie

1,058 Views
harekrishnaroy
Contributor III

Hi All ,

            I am trying to enable pcie. I am trying this on i.Mx6Q sabreauto with SCH-27142-REV C.

As i have browsed on forum and found that this board should support pcie.  But i am getting following error!!

iMX6 PCIe PCIe RC mode imx_pcie_pltfm_probe entering.

PCIE: imx_pcie_pltfm_probe start link up.

link up failed, DB_R0:0x001f3e00, DB_R1:0x08200000!

IMX PCIe port: link down!

I have used L3.0.35_4.1.0_130816_source.tar.gz.

pcie device is of Atheros.

what could be the possible reason for this issue?

Regards ,

Hare Krishna

Labels (2)
1 Reply

177 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Hare

first I would suggest to test verified devices described in attached Linux Manual

sect.35.4 Using PCIe Endpoint and running Tests.

As for atheros pcie suggest to check link

i.MX6Q PCIe EP/RC Validation System

and verify software settings and that card has sufficient power current

CONFIG_IMX_PCIE=y

# CONFIG_IMX_PCIE_EP_MODE_IN_EP_RC_SYS is not set

# CONFIG_IMX_PCIE_RC_MODE_IN_EP_RC_SYS=y

Also for fail detection one can try attached patches.

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------