I.MX6Q first strat boot fail log!

cancel
Showing results for 
Search instead for 
Did you mean: 

I.MX6Q first strat boot fail log!

225 Views
tommyduan
Contributor III

Sometimes the system doesn't work when we first turn on the electricity!The UART LOG as follows,Can you tell me why?

  • It's ok to power up again after failing to start!

    LOG:
  • (180815_14:09:34.776)mxc_free_frame_buf cam->frame[i].vaddress = 0x0
    (180815_14:09:34.793)mxc_free_frame_buf cam->frame[i].vaddress = 0x0
    (180815_14:09:34.908)init: Starting service 'bootanim'...
    (180815_14:09:36.983)capability: warning: `Thread-6' uses 32-bit capabilities (legacy support in use)
    (180815_14:09:39.321)zram: 429 (system_server) Attribute mem_used_total (and others) will be removed. See zram documentation.

Labels (1)
Tags (1)
0 Kudos
1 Reply

124 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi tommy

such issue may happen due to ddr settings, so one can try

to rebuild image with new ddr calibration coefficients found from ddr test

i.MX6/7 DDR Stress Test Tool V2.90 

Other reason may be unstable clock and power subsystem (check power-up

sequence and clock stability with oscilloscope), one can follow i.MX6 System Development

User’s Guide

https://www.nxp.com/docs/en/user-guide/IMX6DQ6SDLHDG.pdf


Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos