How to use the VIV GPU vprovfiler?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to use the VIV GPU vprovfiler?

1,149 Views
Contributor II

I followed the guide of vprovfiler,

  • modify the configure file of GPU driver.

          USE_POWER_MANAGEMENT = 0

          USE_PROFILER                       = 1

  • Extract the pre-built binaries (enable the profile) and replace the libraries

But when I execute the open GLES application, the application crashed, and failure log is: segmentation fault!

Labels (3)
10 Replies

2 Views
Contributor IV

Please clarify which release are you using?

Which backend are you using?

And which application are you using for test?

Thanks.

0 Kudos

2 Views
Contributor II

The kernel verison : 3.0.35 from L3.0.35_4.0.0_130424_source

Backend :

Test application : tutorial1_es20

0 Kudos

2 Views
Contributor IV

Are you using default ltib rootfs?

And please double check if your vdk version is 1.4.5.

Can the Modified kernel co-work is standard rootfs?

Thanks.

0 Kudos

2 Views
Contributor II

Yes, I use the default ltib rootfs, How to get the version of the vdk?

0 Kudos

2 Views
Contributor IV

It should be shown at the VDK package name.

2 Views
Contributor II

Unfortunately, I didn't find the version at the package name, the package is downloaded from https://www.freescale.com/webapp/Download?colCode=I.MX_6DL_S_VIVANTE_VDK_TOOLS&appType=license&locat... and our soc is imx6solo.

0 Kudos

2 Views
Contributor IV

In the package, it shows the vdk tools is for 3.0.0 release. "Linux L3.0.35_3.0.0 GPU Driver with vprofiler"

Please use the correct vdk tool package for 4.0.0 release.

0 Kudos

2 Views
Contributor III

Hello,

I have the same problem about the vprofiler , when I execute the openGLES application (opt/viv_samples/vdk), the application crashed : segmentation fault :smileyblush:

  • I use Kernel 3.0.35 from L3.0.35_4.1.0_130816_source (LTIB).
  • My board = imx6 sabrelite

Have you got a tarball of system with the integrated profiler ?

Regards,

0 Kudos

2 Views
Contributor IV

It should be vtk package.

0 Kudos

2 Views
NXP Employee
NXP Employee

Hi ,

I downloaded the Kernel 3.0.35 adn the VDK tools from i.MX 6 Q/D/DL/S L3.0.35_4.1.0 GA release .

After that I modified the configure file of GPU driver:-

USE_POWER_MANAGEMENT = 0

USE_PROFILER                       = 1

Then i extracted the pre-built binaries (enable the profile) and replace the libraries.

Then as mentioned in the readme file executed the ./ltib command to build.


But now when i am running any OpeGLES application I am getting a Segmentation Fault.


Can somebody please help here?

0 Kudos