How to reflash or recovery initial bootloader(SPI-NOR flash) on IMX6 Sabrelite platform

cancel
Showing results for 
Search instead for 
Did you mean: 

How to reflash or recovery initial bootloader(SPI-NOR flash) on IMX6 Sabrelite platform

17,368 Views
chintakanisiva
Contributor II

Hi All,

When we tried to update the initial boot loader(u-boot) on IMX6 sabrelite quad core platform, some how SPI-NOR flash completely erased and not yet recovered.

We have followed some of the links which is mentioned below to recovery the SPI-NOR boot loader, but we haven't succeeded and we struck at this step. And in this case on serial window nothing has displayed once power up the IMX6 board.

i.MX6x SABRE Lite SPI Flash Recovery - Linux on ARM - eewiki

http://boundarydevices.com/unbricking-nitrogen6x-sabre-lite-i-mx6-board/

Can any one help on this, how to get back the board into normal mode working mode.

Your suggestions are very helpful for us.

Thanks all in advance.

Thanks & Regards

Ch.Siva

26 Replies

887 Views
jamesko
Contributor I

Hi, Eric!

The same problem.

The original boot loader was on the SPI-NOR has been cleared.

USB otg port is broken so it is not available.

Anything can boot only to SD card.

Thanks and Best Regards ,

James

0 Kudos

878 Views
EricNelson
Senior Contributor II

Hi James,

When you say "otg port is broken", do you mean physically broken?

If so, you can contact our office (info@boundarydevices.com) and see about getting it repaired.

0 Kudos

876 Views
jamesko
Contributor I

Hi Eric,

Has produced the current SabreLite circuit board as the base.

I need help.

SabreLite board and elsewhere are as follows:

Item          SabreLite                Coustom

UART       UART2           ->      UART1

SD3          SD                  ->     T-flash

SD4          T-flash            ->     Disable

NAND       Disable          ->      1GB (MT29F8G08ABACA)

DDR3       1GB               ->      2GB (MT41K256M16HA)

RGB port  LCD               ->      GPIO

Where do I need to modify the U-boot?

Do I need to modify the part anywhere below?

board / boundary / nitrogen6x.c and include / configs / nitrogen6x.h

Linux is frustrating because the first time.

*U-boot received from the Boundary site.

*Succeeded to compile and download the SabreLite Board.


Please check the reply.

0 Kudos

876 Views
OtavioSalvador
Senior Contributor II

As Eric said, depending on your deadlines and wishes it may be a challenging task.

jamesko, you will also need trackability, an easy to use development environment and several other small aspects which together will turn your idea into a great product.

0 Kudos

876 Views
EricNelson
Senior Contributor II

Hi James,

Linux is probably the easiest part of your job. You're going to need a custom U-Boot along with a custom Linux kernel.

We're not in the strictly software business, so we can't assist with this. You may want to reach out to others on the list for help.

This is not a job for the inexperienced unless you have quite a bit  of time for learning each of the parts.

0 Kudos

876 Views
jamesko
Contributor I

Sabrelite_USB otg.png

0 Kudos

876 Views
EricNelson
Senior Contributor II

Ouch! This looks horribly burned.

It's also not one of ours...

0 Kudos

876 Views
jamesko
Contributor I

Hi Eric,


Quick reply thank you.

Direct replacement was disconnected while the PCB pattern.

Will not be alone SD card?

0 Kudos

887 Views
tanuj
Contributor I

Hi Everyone,

Is anyone able to reflash original bootloader to SPI-NOR flash.

We followed the steps mentioned in https://wiki.linaro.org/Boards/MX6QSabreLite : for boot from SD.

but after that it erased original bootloader from Flash. No prints comes on serial console.

We tried Mfg Tools with "MX6Q-Sabreauto-SPI_NOR & SD card" profile but still no luck. It is not giving any prints

on serial. Is it possible to put u-boot on SD card and boot from that or it mandatory to put original bootloader to

SPI  NOR flash to getting it functional.

Please help me to resolve this.

Thanks,

0 Kudos

887 Views
dayoungrho
Contributor I

Hi.

I am in same problem with you.

Did you solve it???

If YES, Could you give me some advice??

Regards.

0 Kudos

887 Views
EricNelson
Senior Contributor II

You should use either imx_usb (under Linux) or SB_LOADER.exe under Windows as described in these two posts:

     http://boundarydevices.com/unbricking

     http://boundarydevices.com/windows-users-and-unbricking

0 Kudos

887 Views
dayoungrho
Contributor I

Hey! Thank you for advice!

I am stuck with after that command.

---------------------------------------------------------------------------------------------------------------

...

loading binary file(../u-boot.mx6qsabrelite) to 177ff400, skip=0, fsize=5bc00 type=aa

<<<375808, 375808 bytes>>>
jumping to 0x177ff400

---------------------------------------------------------------------------------------------------------------

Than.

Nothing happend! Do I have to change the mode of swich? or Do I have use command screen???

Or any other way?

I already failed to using way that based windows.

Any tiny hint will be great ! Thanks !

Regards

0 Kudos

887 Views
EricNelson
Senior Contributor II

Hello dayoung,

dayoung rho wrote:

loading binary file(../u-boot.mx6qsabrelite) to 177ff400, skip=0, fsize=5bc00 type=aa

<<<375808, 375808 bytes>>>
jumping to 0x177ff400

The "jumping to..." message says that the binary was downloaded and should be running.

If you're connected with a terminal emulator to the console port, you should see output from U-Boot.

0 Kudos

887 Views
dayoungrho
Contributor I

Hello Eirc!

Your Advice is very helpfu!

Thank you very much!

0 Kudos

887 Views
nehaly_omran
Contributor II


Hello community   ,

i have the same problem that no output from console of u-boot or linux

but i have SD corrupted , so i tried i.MX6x SABRE Lite SPI Flash Recovery - Linux on ARM - eewiki to delete and repartition SD card , copy files but still no output comes out

My question is : what are the files really needed to be on SD card to just be able  to replace corrupted U-boot (i think ) with U-Boot binary from SD card ?? and how this process happens if SPI-NOR itself has been trashed  (as i think too) ??

mentioned link just copy one file to SD card , Boundary devices adds boot/upgrade script files .Linaro link here copied one file usdhc3/4.bin to SD card to be flashed into the SPI NOR in assumption SD has valid U-boot binary/Linux image ??

how do files differ with each situation/problem ?!

my situation is :
-no output from console cable at able (U-boot)

-can not use MFGTool  (USB cable is not detected at all)

-can not use JTAG image download (for any U-boot /application demos) : connection reset by peer

-SD corrupted : tried to format,repartition, copy file to it , still no output at all

i really got confused and stucked with no progress ..

any help is really appreciated ..

Best Regards,

0 Kudos

887 Views
LeonardoSandova
Specialist I

Hi

SD: to reflash a SD, in a linux console type the following command

'dd if=good-u-boot.bin of=/dev/sdX seek=2 skip=2 && sync

SPI-NOR: Try latest manufacturing tool and set choose the SPI-NOR profile

887 Views
nehaly_omran
Contributor II


Hello Leonardo ,

thank you

i tried many times to copy files to SD card but the problem is that U-boot does not get running to be able to copy good-u-boot.bin to SPI-NOR ..

for MFGTool , i can not use it as USB cable is not detected by MFGTool.exe ..

the same cable problem prevents me from using Boundary devices USB_loader utility .

Thanks and Best Regards ,

0 Kudos

887 Views
LeonardoSandova
Specialist I

Strange. EricNelson  any idea?

Leo

0 Kudos

887 Views
EricNelson
Senior Contributor II

Hi Leonardo,

This sounds like a hardware problem of some sort. Our experience is that the RBL just works...

Nehal and I had some back-and-forth on our blog and it sounds like this board is messed up somehow.

0 Kudos

887 Views
prasadeligar
Contributor II

Hi Eric

We are also having a similar board as mentioned by nehal.

We tried to enable the booting of sabre lite board from SD card and during the process erased the contents of SPI NOR.

We followed the steps mentioned in Boards/MX6QSabreLite - Linaro Wiki

After this initially board was getting detected as a HID device.

But after some time we are not able to communicate to the device through USB.

Can you please help me how to determine if the board has gone bad or is there any way to recover it.

Prasad

0 Kudos