How to fix a imx6 Nitrogen6_MAX board not booting anymore (even in USB mode)

Showing results for 
Search instead for 
Did you mean: 

How to fix a imx6 Nitrogen6_MAX board not booting anymore (even in USB mode)

Contributor II

I have been using for the past year this imx6 Nitrogen6_MAX board, mostly in USB mode, since I had to work on u-boot source code. However,  when I tried to start it and use it now (after the weekend), it just does not show anything on the console (UART) port.

Tried both on USB and Normal mode, but same behavior.

Tried with and without an SD card.

Tried original and modified u-boot images (all which worked before).

Tried the unbrick process, but this does not really apply, since I was already working in USB mode.

A few weeks ago it started to behave strangely (the power LED started staying on while the USB cable was plugged in, which was not happening until then).

The USB u-boot loading seems work, as I get the following message:

Interface 0 claimed
HAB security state: development mode (0x56787856)
== work item
filename /home/u-boot
load_size 0 bytes
load_addr 0x00000000
dcd 1
clear_dcd 0
plug 1
jump_mode 2
jump_addr 0x00000000
== end work item
loading DCD table @0x910000

<<<0, 832 bytes>>>
succeeded (status 0x128a8a12)

loading binary file(u-boot) to 177ff400, skip=0, fsize=80c00 type=aa

<<<527360, 527360 bytes>>>
succeeded (status 0x88888888)
jumping to 0x177ff400)

Did anybody encounter this behavior? Is the board done for? Any suggestions?

Thank you,


0 Kudos
1 Reply

Senior Contributor III

Hi Darius,

Have you played with the HAB feature by any chance? Or have you applied a higher power supply voltage by mistake? Have you made any hw modification to the board?

If none of the above ring a bell, please send an email to to discuss other options.



0 Kudos