How to enable WIFI on i.MX 8M Mini EVK?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to enable WIFI on i.MX 8M Mini EVK?

2,496 Views
Contributor I

Hi Folks,

We are testing an i.MX 8M Mini EVK which is running the Linux image (L4.14.78_1.0.0_ga_images_MX8MMEVK). The question is how to enable the WIFI? With the linux terminal, we only see eth0 and lo. Much appreciate any advice. Thank you. Screen Shot 2019-03-14 at 3.14.35 PM.png

8 Replies

162 Views
Contributor II

Mini tutorial on how I got my board's WiFi up. Took me a while so might be helpful to someone.

Board:   MCIMX8M-EVK

Linux:     L4.14.98_2.0.0 (should work with 4.78)

Use iwconfig instead of ifconfig to bring interface up:

   ifconfig wlan0 up

Check if it works by scanning for SSIDs:

   iwlist wlan0 scan

Use editor to edit /etc/wpa_supplicant.conf :

   mcedit /etc/wpa_supplicant.conf

Change the Network block to as follows (keep the quotation marks):

   Network={
      scan_ssid=1
      ssid="YOUR_SSID_NAME"
      psk="YOUR_PASSWORD"
   }

Associate the wlan with config:
   wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf

Check if you have right SSID associated now:

   iwconfig wlan0

Rung DHCP client from BusyBox to get the IP (yup, there is no dhclient):
   udhcpc -i wlan0

Check the network:
   ping www.google.com

#wifi‌imx 8m‌ #imx8mq_evk #yocto imx‌ 

162 Views
Contributor II

Hi Harijs,

I have the same problem of OP but following your instructions i've got the following results:

root@imx8m-var-dart:~# iwlist wlan0 scan
wlan0     Interface doesn't support scanning.

root@imx8m-var-dart:~# iwconfig wlan0
wlan0     no wireless extensions.

root@imx8m-var-dart:~# wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
rfkill: Cannot open RFKILL control device
brcmfmac: brcmf_cfg80211_add_iface: iface validation failed: err=-16
Failed to create interface p2p-dev-wlan0: -16 (Device or resource busy)
nl80211: Failed to create a P2P Device interface p2p-dev-wlan0
P2P: Failed to enable P2P Device interface
root@imx8m-var-dart:~#

Any idea to resolve this?

Thanks in advance

Best regards

Andrea

0 Kudos

162 Views
Contributor II

@Andrea Maccanti,

Hey. In case you still have the issue of getting WiFi up - I just set up the imx8m-mini-evk with L4.19.35_1.1.0 from imx-image-full-imx8mmevk.sdcard image and noticed that the iwconfig and iwlist are missing. Also, I was in a bit of hurry and for some reason I could not get the DNS to work straight out of the box. It said "Temporary failure in name resolution".  So I used the ifconfig and google IP for ping instead. 

 

To recap, I got it up by:

1. Use ifconfig to bring interface up:

   ifconfig wlan0 up

2. Use editor to edit /etc/wpa_supplicant.conf :

   mcedit /etc/wpa_supplicant.conf

3. Change the Network block to as follows (keep the quotation marks):

   Network={
      scan_ssid=1
      ssid="YOUR_SSID_NAME"
      psk="YOUR_PASSWORD"
   }

 

4. Associate the wlan with config:
   wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf

 

5. Check if you wlan is up:

   ifconfig wlan0

 

6. Rung DHCP client from BusyBox to get the IP (yup, there is no dhclient):
   udhcpc -i wlan0

 

7. Check the network:
   ping 8.8.8.8

Anyway, hope it helps.

Harry.

0 Kudos

162 Views
Contributor V

Can you try the following command to start wpa_supplicant?

$wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf -D nl80211

See if this makes any difference?

0 Kudos

162 Views
Contributor II

Hi Romit,

thanks for your reply, i tried the command you suggested but i've got the same result as the other one:

root@imx8m-var-dart:~# wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf -D nl80211
Successfully initialized wpa_supplicant
rfkill: Cannot open RFKILL control device
brcmfmac: brcmf_cfg80211_add_iface: iface validation failed: err=-16
Failed to create interface p2p-dev-wlan0: -16 (Device or resource busy)
nl80211: Failed to create a P2P Device interface p2p-dev-wlan0
P2P: Failed to enable P2P Device interface

I've also tried to use rfkill list but it gives me the following response:

root@imx8m-var-dart:~# rfkill list
rfkill: cannot open /dev/rfkill: No such file or directory
rfkill: cannot read /dev/rfkill: Bad file descriptor

Any idea?

0 Kudos

162 Views
Contributor V

Have you tried the demo image from NXP (https://www.nxp.com/webapp/sps/download/license.jsp?colCode=L4.14.98_2.0.0_MX8MM&appType=file1&DOWNL...), or are you building your own image? In case you are building the image yourself, perhaps it might be worthwhile to try with the demo image once. That might narrow down the issue between software and hardware. 

0 Kudos

162 Views
Contributor I

This is clutch!! Thanks a lot for this.

0 Kudos

162 Views
NXP TechSupport
NXP TechSupport

Hi Di

one can try procedures described in sect.4.13 Wi-Fi attached Linux Manual.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------