How to close log output of systemd

cancel
Showing results for 
Search instead for 
Did you mean: 

How to close log output of systemd

76 Views
Contributor I

dear expert

     we want minimize linux start time , we found the systemd log output on console may use long time , so we want close it's output ;

    we want close systemd output but have no influence to console login  , how to do it ?

 

the log like follow :

[ 3.904236] systemd-gpt-auto-generator[2177]: Failed to dissect: Input/output error
[ 4.041964] random: systemd: uninitialized urandom read (16 bytes read)
[ OK ] Created slice System Slice.
[ 4.062002] random: systemd: uninitialized urandom read (16 bytes read)
[ OK ] Listening on udev Control Socket.
[ 4.082095] random: systemd: uninitialized urandom read (16 bytes read)
[ OK ] Listening on Network Service Netlink Socket.
[ OK ] Listening on Journal Socket.
Mounting Huge Pages File System...
Mounting Kernel Debug File System...
[ OK ] Listening on Journal Socket (/dev/log).
[ OK ] Started Dispatch Password Requests to Console Directory Watch.
[ OK ] Reached target Swap.
Mounting POSIX Message Queue File System...
Starting Load Kernel Modules...
Mounting Temporary Directory (/tmp)...
[ OK ] Created slice system-serial\x2dgetty.slice.
[ OK ] Reached target System Time Synchronized.
[ OK ] Reached target Remote File Systems.
[ OK ] Reached target Host and Network Name Lookups.
Starting dias bsp bring up...
[ OK ] Created slice system-getty.slice.
[ OK ] Started Forward Password Requests to Wall Directory Watch.
[ OK ] Listening on Syslog Socket.
[ OK ] Listening on udev Kernel Socket.
[ OK ] Listening on /dev/initctl Compatibility Named Pipe.
[ OK ] Reached target Paths.
[ OK ] Listening on Journal Audit Socket.
Starting Journal Service...
[ 4.400596] systemd-journald[2189]: /etc/systemd/journald.conf:36: Not

.............

 

     thanks

0 Kudos
4 Replies

4 Views
NXP TechSupport
NXP TechSupport

Also please try to remove "console:" option from the Device Tree as well.

0 Kudos

68 Views
NXP TechSupport
NXP TechSupport

Please try systemd.log_target=null boot option.

0 Kudos

40 Views
Contributor I

it seems it can not be added to cmdline :

i add it in uboot bootargs , after linux startup , i read /proc/cmdline , the systemd item is not in it;

i add it in dts , it show compile error;

 

 

0 Kudos

57 Views
Contributor I

i set LogTarget=null in /etc/systemd/system.conf , but it's not work ;

should i add it in cmdline ?

thanks

0 Kudos