How do I enable CONFIG_SND_DMA_SGBUF?

cancel
Showing results for 
Search instead for 
Did you mean: 

How do I enable CONFIG_SND_DMA_SGBUF?

Jump to solution
323 Views
andrewellis
Contributor III

Hi,

I'm trying to build a sound card driver for my project, but when I build the driver the build process fails with the error:

/home/user/Drivers/MircoGrabber/Linux/audio/grabber-audio.c:96:9: error: implicit declaration of function 'snd_pcm_substream_sgbuf' [-Werror=implicit-function-declaration]

I have found that snd_pcm_substream_sgbuf is located in \linux3.0.35\include\sound\pcm.h

There is above a define:

#ifdef CONFIG_SND_DMA_SGBUF

My question is: where in the kernel build menu do I enable CONFIG_SND_DMA_SGBUF? I'm assuming that some where there is another dependancy that I've not yet found?

I'm using the SabreSD board.

Kind regards

Andrew


Labels (3)
0 Kudos
1 Solution
158 Views
juangutierrez
NXP Employee
NXP Employee

I just quickly look for the kconfig containing this config and it seems it depends on x86 arch :smileysad:

===== file: sound/core/Kconfig ======

config SND_DMA_SGBUF

        def_bool y

        depends on X86

View solution in original post

0 Kudos
2 Replies
159 Views
juangutierrez
NXP Employee
NXP Employee

I just quickly look for the kconfig containing this config and it seems it depends on x86 arch :smileysad:

===== file: sound/core/Kconfig ======

config SND_DMA_SGBUF

        def_bool y

        depends on X86

View solution in original post

0 Kudos
158 Views
andrewellis
Contributor III

Oh dear :smileysad: It looks like I'm going to have to try and find another solution

0 Kudos