How can i get the L5.4.24_2.1.0 Linux binary demo files for MX8QM

cancel
Showing results for 
Search instead for 
Did you mean: 

How can i get the L5.4.24_2.1.0 Linux binary demo files for MX8QM

180 Views
Contributor I

Hello,

I found there is the L5.4.24 version Linux binary for MX8DX but the Linux version for MX8QMMEK seem still not available. How can I get the L5.4.24 version for my MX8QMMEK board.

I followed the "i.mx yocto project user's guide" labeled as  " Rev. L5.4.24_2.1.0 , 06/2020" step by step to make the imx8qmmek fsl-image-qt5-validation-imx but there were errors as below.  How can I handle this problem?

ERROR: Multiple .bb files are due to be built which each provide opencl-headers:################ | ETA: 0:00:03
yocto-imx8qm/sources/meta-imx/meta-bsp/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.0.p2.2-aarch64.bb
yocto-imx8qm/sources/meta-openembedded/meta-oe/recipes-core/opencl-headers/opencl-headers_git.bb
A list of tasks depending on these providers is shown and may help explain where the dependency comes from.
yocto-imx8qm/sources/meta-imx/meta-bsp/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.0.p2.2-aarch64.bb has unique dependees:
yoyocto-imx8qm/sources/poky/meta/recipes-graphics/mesa/libglu_9.0.1.bb:do_prepare_recipe_sysroot
yoyocto-imx8qm/sources/poky/meta/recipes-connectivity/libpcap/libpcap_1.9.1.bb:do_build
yoyocto-imx8qm/sources/meta-imx/meta-sdk/recipes-fsl/packagegroup/packagegroup-fsl-tools-gpu-external.bb:do_build
yoyocto-imx8qm/sources/meta-imx/meta-sdk/recipes-graphics/vulkan/vkmark_1.0.bb:do_prepare_recipe_sysroot
yoyocto-imx8qm/sources/meta-imx/meta-bsp/recipes-graphics/nn-imx/nn-imx_1.0.4.bb:do_package
yoyocto-imx8qm/sources/meta-openembedded/meta-oe/recipes-graphics/freeglut/freeglut_3.0.0.bb:do_package
yoyocto-imx8qm/sources/meta-qt5/recipes-qt/qt5/qtgraphicaleffects_git.bb:do_build
yoyocto-imx8qm/sources/poky/meta/recipes-graphics/pango/pango_1.44.6.bb:do_build
.......

Thanks in advance

Taotao Wang

0 Kudos
1 Reply

108 Views
NXP TechSupport
NXP TechSupport

refer to the yocto user guide, fsl-image-qt5-validation-imx isn't supported for 5.4.24 anymore, pls reer to the chapter 5.2 Choosing an i.MX Yocto project image of yocto user guide, you can choose "imx-image-multimedia" or "imx-image-full"

0 Kudos