Hostapd service stops working when it is configured for 802.11ac mode

cancel
Showing results for 
Search instead for 
Did you mean: 

Hostapd service stops working when it is configured for 802.11ac mode

Jump to solution
390 Views
Vidhi_V
Contributor I

Hello,

I am working on sd8887 based Wi-Fi module interfaced with i.mx6 Dual Lite board which is having 2.5 GHz bandwidth support in both AP and Station mode. Both the modes are woking fine with 2.5 GHz band. I have verified the Station mode capabilities of the board for 5GHz band and board is able to switch successfully from 2.5 to 5 GHz & communicates well with the mobile hotspot supporting 5GHz band. The problem arises when I configure the board to be operated with 5GHz in AP mode. When I try to configure hostapd.conf compatible with 5GHz, the hostapd service stops running. 

My hostapd configuration :

country_code=US

hw_mode=a
channel=36
ieee80211n=1
ieee80211d=1
ieee80211ac=1
vht_oper_chwidth=1
vht_oper_centr_freq_seg0_idx=42
auth_algs=1
ignore_broadcast_ssid=0
wpa=3
wpa_passphrase=12345678
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP

The file dumped with "iw list" command output, is attached below.

Note : Driver side support is added for device to work efficiently with 5GHz Band as well. 

Is there anything that I'm missing over here? Your inputs will be quite helpful. Kindly share your thoughts/suggestions for the same.

Thank you.

0 Kudos
1 Solution
358 Views
Vidhi_V
Contributor I

Hiii,

The mentioned query was resolved by doing following changes.

1. Check if your hostapd build configuration has enabled the CONFIG options for 80211ac mode or not. If yes then above hostapd.conf should work. 

2. If not then you can download the standard hostapd from this site : https://wireless.wiki.kernel.org/en/users/documentation/hostapd

3. Download it and check deconfig file from the directory. You will find the options to enable 802.11ac mode like CONFIG_IEEE80211AC, CONFIG_ACS etc. as per your chipset module. For further parameters one can read the description of each parameter in decofig file as enable as per the requirement.

4. Configure the changes in your board's hostapd deconfig file and rebuild the kernel.

5. After that, configure hostapd.conf as mentioned in the query and you're good to go!!!

 This worked in my case. Hope this will help others too.

 

regards,

Vidhi Vadher

View solution in original post

0 Kudos
1 Reply
359 Views
Vidhi_V
Contributor I

Hiii,

The mentioned query was resolved by doing following changes.

1. Check if your hostapd build configuration has enabled the CONFIG options for 80211ac mode or not. If yes then above hostapd.conf should work. 

2. If not then you can download the standard hostapd from this site : https://wireless.wiki.kernel.org/en/users/documentation/hostapd

3. Download it and check deconfig file from the directory. You will find the options to enable 802.11ac mode like CONFIG_IEEE80211AC, CONFIG_ACS etc. as per your chipset module. For further parameters one can read the description of each parameter in decofig file as enable as per the requirement.

4. Configure the changes in your board's hostapd deconfig file and rebuild the kernel.

5. After that, configure hostapd.conf as mentioned in the query and you're good to go!!!

 This worked in my case. Hope this will help others too.

 

regards,

Vidhi Vadher

0 Kudos