Having problems on ethernet DHCP on SabreDL with Freescale Android

cancel
Showing results for 
Search instead for 
Did you mean: 

Having problems on ethernet DHCP on SabreDL with Freescale Android

Jump to solution
906 Views
RafaelThomasGoz
Contributor III

Hi,

we have deployed Android 4.3 from Freescale on a Sabre DL. Now we are facing problems to get IPs on ethernet using DHCP or even statically set IPs.

Using DHCP we get the following:

30|root@tcandroid:/ # dhcpcd eth0

dhcpcd[3421]: flock `/data/misc/dhcp/dhcpcd-eth0.pid': Try again

1|root@tcandroid:/ # dhcpcd eth0                                              

dhcpcd[3423]: version 5.5.6 starting

dhcpcd[3423]: eth0: checking for 169.254.85.56

dhcpcd[3423]: eth0: using IPv4LL address 169.254.85.56

dhcpcd[3423]: forked to background, child pid 3448


Which is wrong since it is getting a link-local address.


Setting a static IP we can set it but we cannot ping anything on the network:

ifconfig eth0 192.168.1.12

route add default dev eth0   

ping 192.168.1.1


Getting:


PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

From 192.168.1.177: icmp_seq=1 Destination Host Unreachable

From 192.168.1.177: icmp_seq=2 Destination Host Unreachable

From 192.168.1.177: icmp_seq=3 Destination Host Unreachable

From 192.168.1.177: icmp_seq=5 Destination Host Unreachable

From 192.168.1.177: icmp_seq=6 Destination Host Unreachable


It works fine with a Linux deployed (Debian kernel 3.0.35), so hardware is not the issue.


Any suggestions on how to further debug it?


Labels (3)
0 Kudos
1 Solution
83 Views
RafaelThomasGoz
Contributor III

Hi Thomas,

actually we had a problem on the eMMC communication that was not using its full speed. So reducing the emmc communication speed, it was also limiting the Ethernet speed. Similarly to what you have suggested.

We have fixed the emmc communication bus and now we can get full gigabit ethernet.

View solution in original post

0 Kudos
7 Replies
83 Views
SergioSolis
NXP Employee
NXP Employee

Hello Rafael,

So you do not have internet at all correct?.. are you behind a proxy? ... android is pretty straightforward on this, you shouldn't have any problems right after plugging the ethernet cable.

Any messages on the terminal window?

0 Kudos
83 Views
RafaelThomasGoz
Contributor III

By Terminal Window you mean logcat messages? If so no, just the failure on DHCP.

In the previous post I have pasted the dmesg messages.

0 Kudos
83 Views
SergioSolis
NXP Employee
NXP Employee

Hello Rafael,

Are you still having the same issue with the network?

0 Kudos
83 Views
RafaelThomasGoz
Contributor III

Actually we ended by setting the speed of Ethernet driver to only 10mbps. If we set it higher it cannot get DHCP. We are still investigating why.

0 Kudos
83 Views
athomas
Contributor III

Did you check the CPU freq? Clock it up all the way to 996 MHz. That goes along with what you are observing about having to use a slower rate.

0 Kudos
84 Views
RafaelThomasGoz
Contributor III

Hi Thomas,

actually we had a problem on the eMMC communication that was not using its full speed. So reducing the emmc communication speed, it was also limiting the Ethernet speed. Similarly to what you have suggested.

We have fixed the emmc communication bus and now we can get full gigabit ethernet.

View solution in original post

0 Kudos
83 Views
athomas
Contributor III

I had trouble with networking if the clock/cpu_freq was set too low in Debian. You have a lot of options for setting via Debian. You can use cpufreq-info/set in Debian to check which freq and CPU governor is being used.

I am not sure how Andriod sets it up, but you may want to check that. Andriod may be more low-power first, performance second.

0 Kudos