Has anyone tried compiling freeswitch to imx6ull evk?

Showing results for 
Search instead for 
Did you mean: 

Has anyone tried compiling freeswitch to imx6ull evk?

Contributor II


I have a imx6ull evk and I'm atrying to build freeswitch to run on this board. I followed the instructions here Debian 8 Jessie - FreeSWITCH - Confluence  in the part that says compiling from source code and I'mtrying to compile it on my board insted of crosscompiling.

But I have a problem when it gets to the make command. For some reason it enters an infinite loop in the vpx, vp9 and vp8 folders. It literally says the following

"make[2]:  Warning: File /usr/include/stdc-predef.h" has modifiction time x s in the future"

After that starts sputing [DEP] vpx/src/...

Rinse and repeat. It starts outputting the same text to the screen again. Of course I tried running make -p and outputting to a file for debugging purposes but it's simply too large for me to debug, but it seems to be doing the joob accordingly. My problem with this is that  I left it compiling freeswitch for 48 an entire weekend and it kept outputting the same text and nothing happened.

PS: I used this linkhttps://community.nxp.com/docs/DOC-334274  for the installation of debian on my board and am now trying to create a minimal rootfs (not the linaro one) and compile it from source in a ubuntu VM and then flash my device

0 Kudos
0 Replies