HDMI-to-VGA Issue - iMX6 Custom Board

cancel
Showing results for 
Search instead for 
Did you mean: 

HDMI-to-VGA Issue - iMX6 Custom Board

121 Views
Contributor I

Hi,

We're having a problem with our custom board (iMX6) that has an HDMI port, with connected HDMI-to-VGA converter. We've already tried it with "TRUE" HDMI and it's working fine. But with the converter we have, its not working. I already tried all the fixes regarding with this issue and nothing worked.

The problem I see is that, when connecting the converter to the laptop with HDMI port, and probing the HDMI clock, the voltage is approx. 5V. But when connecting it to our board, it drops at about approx. 2.3V with a resolution of 1024x768. Is it okay to have a voltage drop when connecting the converter? if not, can you provide a solution or hint on what to be modified on the driver to make it worked? BTW, the chip that is embedded on the converter is CM6616E.

Thank you.

Best Regards,

Ben

Labels (1)
0 Kudos
1 Reply

25 Views
NXP TechSupport
NXP TechSupport

Hi Benedick

one can try patches provided on

https://boundarydevices.com/dvi-support-on-i-mx6-boards/ 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos