HDMI Screen Is flicking in I.MX8QM board when using kernel version 5.15.32

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

HDMI Screen Is flicking in I.MX8QM board when using kernel version 5.15.32

470 Views
mallibeerala
Contributor III

Hi,

HDMI screen flicking in i.MX8QM board when using kernel version 5.15.32, but HDMI screen is coming properly in kernel version 4.14.98.

When weston services disable issue is not coming.

When weston services enabled error logged as "[drm] [CRTC:38:crtc-0] dpu_crtc_atomic_flush: FrameGen requests to read empty FIFO"

I am getting attached video when weston services are enabled.

Thanks & Regards,
Mallikarjuna.

0 Kudos
3 Replies

442 Views
Sanket_Parekh
NXP TechSupport
NXP TechSupport

Hi @mallibeerala,

 
I hope you are doing well
 
We suspect that this type of data underrun error may occur because of performance limitations mentioned in the ERRATA.
Please refer to the ERR050183: DC: 4Kp60 performance limitations from the Mask Set Errata IMX8_1N94W.
One can try the workaround given in the same to solve the issue.
 
Thanks & Regards,
Sanket Parekh
0 Kudos

433 Views
mallibeerala
Contributor III

Hi Sanket parekh,

I am processing 1366x768 resolution data, it is working fine for 1024x768 resolution data without set "use-g2d=1"

While I am enabling "use-g2d=1" in weston.ini, screen flickering is stopped but I am unable to connect to wayland display.

While I am running wayland application I am getting message as "Can't connect to wayland display !?".

While I am running "systemctl restart weston" command I am getting below errors

     1) [CRTC:38:crtc-0] dpu_crtc_atomic_flush: wait for content shdld done timeout

     2) Job for weston.service failed because the control process exited with error code.


Below is the script file I am running for weston.ini

[core]
#gbm-format=argb8888
#gbm-format=rgb565
idle-time=0
use-g2d=1
#xwayland=true
drm-device=card0
repaint-window=16
#enable-overlay-view=1
modules=screen-share.so

[shell]
#panel-position="none
#background-color=0xFF00000
#size=1920x1080

[libinput]
touchscreen_calibrator=true

#[output]
#name=HDMI-A-1
#mode=1920x1080@60
#transform=rotate-90

#[output]
#name=HDMI-A-2
#mode=1366x768@60
# WIDTHxHEIGHT Resolution size width and height in pixels
# off Disables the output
# preferred Uses the preferred mode
# current Uses the current crt controller mode
#transform=rotate-90

[screen-share]
#command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize --rdp-tls-cert=/etc/freerdp/keys/server.crty
#start-on-startup=true

Please help us to resolve this issue.

Thanks & Regards,
Mallikarjuna

0 Kudos

361 Views
Sanket_Parekh
NXP TechSupport
NXP TechSupport

Hi @mallibeerala,

I hope you are doing well

It is recommended to use the latest kernel.

There is the latest kernel commit for this error. Please find the same from the below link.
https://github.com/nxp-imx/linux-imx/commit/70744429841f08efc42a63380198cdae7f9a602f

All previous workaround on this 'dpu-crtc.c' driver can be found from the link given below.
https://github.com/nxp-imx/linux-imx/commits/lf-6.1.y/drivers/gpu/drm/imx/dpu/dpu-crtc.c

I hope this information helps you.

Thanks & Regards,
Sanket Parekh

0 Kudos