HDMI Error on I.MX6Q SDB

cancel
Showing results for 
Search instead for 
Did you mean: 

HDMI Error on I.MX6Q SDB

Jump to solution
2,455 Views
ArcheeW
Contributor I

Hi,

   I run android4 on mx6q sdb.

   the BSP : imx-android-r13.4-ga, and patch use :r13.4-ga_sdb_sdp;

 

  After I set up u-boot cmd as :

    setenv bootargs console=ttymxc0,115200 androidboot.console=ttymxc0 vmalloc=400M init=/init video=mxcfb0:dev=hdmi,1920x1080M@60 video=mxcfb1:off video=mxcfb2:off fbmem=28M

 

   and saveenv ; reset the board.  When I plug the HDMI to VGA connector, the debug serial output:

/////////////////////////////////////////////////////////

  fbcvt: 1920x1080@60: CVT Name - 2.073M9

mxc_hdmi mxc_hdmi: same edid

.........

mxc_hdmi mxc_hdmi: same edid

////////////////////////////////////////////////////////

But, the HDMI Monitor show nothing.

 

Is someone know why!?

 

Thanks!

 

 

 

 




 


Original Attachment has been moved to: debug.txt.zip

Labels (3)
Tags (1)
0 Kudos
1 Solution
128 Views
hemalgandhi
Contributor III

Hi,

After reviewing attached log, it looks that android is booted successfully. If you are using HDMI to VGA connector, you need to set input signal as VGA from your Display unit.

If your display supports HDMI input directly, you can try to connect board with Display unit using HDMI to HDMI cable and adjust input signal as HDMI from  your display unit.



Thanks,

Hemal

View solution in original post

0 Kudos
3 Replies
128 Views
hoangduong
Contributor II

Hi ArcheeWoo,

At this moment, i have same problem. I set up uboot cmd as you did and i see the kernel message show

fbcvt: 1920x1080@60: CVT Name - 2.073M9

but when android boot up, i can not see anything on HDMI monitor, i also went to display advanced options on android settings but HDMI settings not there. I also use a HDMI to VGA cable.

did you resolve this problem?

Thanks.

0 Kudos
128 Views
fabiof
Contributor IV

Hi

I currently have the same problem too, some news about possible fix?

Thank you

0 Kudos
129 Views
hemalgandhi
Contributor III

Hi,

After reviewing attached log, it looks that android is booted successfully. If you are using HDMI to VGA connector, you need to set input signal as VGA from your Display unit.

If your display supports HDMI input directly, you can try to connect board with Display unit using HDMI to HDMI cable and adjust input signal as HDMI from  your display unit.



Thanks,

Hemal

View solution in original post

0 Kudos