G2D problems during 'bitbake imx-image-multimedia' for IMX8QM/Yocto-4.19

cancel
Showing results for 
Search instead for 
Did you mean: 

G2D problems during 'bitbake imx-image-multimedia' for IMX8QM/Yocto-4.19

317 Views
RobbieJiang
Contributor IV

We are trying to build imx-image-multimedia  with imx gstreamer plugins for MX8QM and Linux -4.19.45.

The yocto is 4.19-warrior.

First, we add following lines to 'local.conf':

IMAGE_INSTALL_append = " gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly imx-gpu -g2d imx-gpu-viv gstreamer1.0-plugins-imx imx-gst1.0-plugin "
LICENSE_FLAGS_WHITELIST = "commercial"

And run 'bitbake imx-image-multimedia':

Finally we got the following errors:

jiejiang@ubuntu:~/imx8_yocto_bsp/build-xwayland$ bitbake imx-image-multimedia
Loading cache: 100% |####################################################################################################################| Time: 0:00:00
Loaded 3921 entries from dependency cache.
Parsing recipes: 100% |##################################################################################################################| Time: 0:00:02
Parsing of 2784 .bb files complete (2782 cached, 2 parsed). 3921 targets, 207 skipped, 4 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies
ERROR: Nothing RPROVIDES 'imx-gpu-g2d' (but /home1/jiejiang/imx8_yocto_bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/images/imx-image-multimedia.bb RDEPENDS on or otherwise requires it)
imx-gpu-g2d was skipped: PREFERRED_PROVIDER_virtual/libg2d set to imx-dpu-g2d, not imx-gpu-g2d
imx-gpu-g2d was skipped: PREFERRED_PROVIDER_virtual/libg2d set to imx-dpu-g2d, not imx-gpu-g2d
NOTE: Runtime target 'imx-gpu-g2d' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['imx-gpu-g2d']
ERROR: Required build target 'imx-image-multimedia' has no buildable providers.
Missing or unbuildable dependency chain was: ['imx-image-multimedia', 'imx-gpu-g2d']

Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

 

There are two 'virtual/libg2d' providers in the bitbake recipes :

sources/meta-freescale/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.4.8.bb

sources/meta-freescale/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.8.bb

 

Both recipes include 'PROVIDES += "virtual/libg2d"

However,  'bitbake -c compile imx-gpu-g2d' failed.

 

jiejiang@ubuntu:~/imx8_yocto_bsp/build-xwayland$ bitbake -c compile imx-dpu-g2d
Loading cache: 100% |####################################################################################################################| Time: 0:00:00
Loaded 3921 entries from dependency cache.
NOTE: Resolving any missing task queue dependencies

Build Configuration:
BB_VERSION = "1.42.0"
BUILD_SYS = "x86_64-linux"
NATIVELSBSTRING = "ubuntu-16.04"
TARGET_SYS = "aarch64-poky-linux"
MACHINE = "imx8qmmek"
DISTRO = "fsl-imx-xwayland"
DISTRO_VERSION = "4.19-warrior"
TUNE_FEATURES = "aarch64"
TARGET_FPU = ""
meta
meta-poky = "HEAD:6d2e12e79211b31cdf5ea824fb9a8be54ba9a9eb"
meta-oe
meta-multimedia = "HEAD:3bdbf72e3a4bf18a4a2c7afbde4f7ab773aeded9"
meta-freescale = "HEAD:2142f7ded1b3115ccc21f7575fd83e2376247193"
meta-freescale-3rdparty = "HEAD:da422478d38e744283bcf61123c4a526396c7030"
meta-freescale-distro = "HEAD:d4e77ea682fa10d0d54a723b3d3099c44fc5e95c"
meta-bsp
meta-sdk
meta-ml = "HEAD:bb05c60e6398b374ac49554c642a3bef36452f73"
meta-browser = "HEAD:5f365ef0f842ba4651efe88787cf9c63bc8b6cb3"
meta-rust = "HEAD:11aed43748d7dd194dc6c06a35a16104400d1090"
meta-gnome
meta-networking
meta-python
meta-filesystems = "HEAD:3bdbf72e3a4bf18a4a2c7afbde4f7ab773aeded9"
meta-qt5 = "HEAD:dc2dedef9961950b88f4245ba7499538ec4244ab"

Initialising tasks: 100% |###############################################################################################################| Time: 0:00:00
Sstate summary: Wanted 0 Found 0 Missed 0 Current 33 (0% match, 100% complete)
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
NOTE: Tasks Summary: Attempted 257 tasks of which 251 didn't need to be rerun and all succeeded.

 


jiejiang@ubuntu:~/imx8_yocto_bsp/build-xwayland$ bitbake -c compile imx-gpu-g2d
Loading cache: 100% |####################################################################################################################| Time: 0:00:00
Loaded 3921 entries from dependency cache.
ERROR: Nothing PROVIDES 'imx-gpu-g2d'
imx-gpu-g2d was skipped: PREFERRED_PROVIDER_virtual/libg2d set to imx-dpu-g2d, not imx-gpu-g2d
imx-gpu-g2d was skipped: PREFERRED_PROVIDER_virtual/libg2d set to imx-dpu-g2d, not imx-gpu-g2d

Summary: There was 1 ERROR message shown, returning a non-zero exit code.

 

How to fix this problem?

0 Kudos
3 Replies

306 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello Robbie,

 

Please move a supported kernel is based on 4.19.35 or 5.4.24 linux kernels, now the imx-gpu-g2d is not supported anymore you should try bitbake -c compile imx-dpu-g2d.

 

Regards

 

0 Kudos

273 Views
RobbieJiang
Contributor IV

Hi,

Thanks for your reply.

I tried to remove 'imx-gpu-g2d' from local.conf.

However, there is still NO v4l2h264enc / vl42h264dec plugins on my MX8QM board 

root@imx8qmmek:~# gst-inspect-1.0 | grep h264
videoparsersbad: h264parse: H.264 parser
rtp: rtph264pay: RTP H264 payloader
rtp: rtph264depay: RTP H264 depayloader
uvch264: uvch264src: UVC H264 Source
uvch264: uvch264mjpgdemux: UVC H264 MJPG Demuxer
typefindfunctions: video/x-h264: h264, x264, 264

 

The rootfs is build by 'bitbake imx-image-multimedia',

and here is my local.conf:

MACHINE ??= 'imx8qmmek'
DISTRO ?= 'fsl-imx-xwayland'
PACKAGE_CLASSES ?= 'package_rpm'
EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
USER_CLASSES ?= "buildstats image-mklibs image-prelink"
PATCHRESOLVE = "noop"
BB_DISKMON_DIRS ??= "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
STOPTASKS,/tmp,100M,100K \
ABORT,${TMPDIR},100M,1K \
ABORT,${DL_DIR},100M,1K \
ABORT,${SSTATE_DIR},100M,1K \
ABORT,/tmp,10M,1K"
PACKAGECONFIG_append_pn-qemu-system-native = " sdl"
PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
CONF_VERSION = "1"

DL_DIR ?= "${BSPDIR}/downloads/"
ACCEPT_FSL_EULA = "1"
IMAGE_INSTALL_append = " gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly imx-gpu-viv  imx-gst1.0-plugin "
LICENSE_FLAGS_WHITELIST = "commercial"

 

Anything wrong?

And how can I build and install v4l2h264enc / v4l2h264dec plugins on my MX8QM / yocto(4.19 warrior) system?

 Regards.

0 Kudos

251 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello ,

According to attached Release Notes p.36 for i.MX8QM v4l2h264enc

is used, not vpuenc_h264, like:

gst-launch-1.0 v4l2src device=/dev/video0 num-buffers=300 io-mode=dmabuf ! \
'video/x-raw,format=(string)NV12,width=1920,height=1080,framerate=(fraction)30/1' ! \
queue ! v4l2h264enc output-io-mode=dmabuf-import ! \
avimux ! filesink location=test.avi

 

Regards

 

0 Kudos