Failed to capture v4l2 frame after resuming from Suspend_to_RAM

cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to capture v4l2 frame after resuming from Suspend_to_RAM

65 Views
RobbieJiang
Contributor IV

system: I.MX8QM / Yocto 5.4 BSP

HW connection:

Camera sensor -> TI 935(Serializer) -> TI 960(Deserializer) -> MX8 MIPI-CSI2

 

Hardware and drivers work well and sensor image can be captured via V4L2 interface after power-on or rebooting. The size of file 'test.yuv' keeps increasing when executing this command after power-on or rebooting:

gst-launch-1.0 -v v4l2src device=/dev/video2 ! filesink location=test.yuv sync=false async=false

 

However, we failed to capture sensor image after 'deep system sleep', i.e, SUSPEND_TO_RAM.

You can repeat the problem using the following test commands:

#enable wakeup system from debug UART
echo enabled > /sys/class/tty/ttyLP0/power/wakeup

#deep sleep, SUSPEND_TO_RAM
echo mem > /sys/power/state


System suspending works as expected.

Then to capture sensor image after waking up the system from debug UART:

gst-launch-1.0 -v v4l2src device=/dev/video2 ! filesink location=test.yuv sync=false async=false


There is no image frame captured successfully because the size of file 'test.yuv' is always 0.

 

Note that  if the system is suspended to 'freeze':
echo freeze > /sys/power/state

Everything works well and sensor image can be captured successfully after system resuming.


How to fix this problem?

 

0 Kudos
1 Reply

59 Views
igorpadykov
NXP TechSupport
NXP TechSupport
0 Kudos