Enable bluez utilities in IMX8QXP

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Enable bluez utilities in IMX8QXP

2,494 Views
jnj
Contributor III

Hi All,

I am currently working on L5.10 on the imx8qxp MEK board. I want to enable hciattach and hcitool on the imx8qxp. How can we enable the same in L5.10?Kindly help.

 

Thanks in advance!

 

 

 

0 Kudos
Reply
11 Replies

2,481 Views
Harvey021
NXP TechSupport
NXP TechSupport

Hi, 

Both tools should be included in BSP (also with 5.10) by default.

 

Regards

Harvey

0 Kudos
Reply

2,478 Views
jnj
Contributor III

Hi @Harvey021 ,

Thank you for the prompt response. After yocto build and flashing , I am not able to find hciattach,hciconfig and hcitool .

0 Kudos
Reply

2,463 Views
jnj
Contributor III

Hi @Harvey021 ,

I checked with pre-built images. In the prebuilt images, hciattach, hcitool, and hciconfig are present. However, after executing 'repo init' and 'repo sync' commands (repo init -u https://github.com/nxp-imx/imx-manifest -b imx-linux-hardknott -m imx-5.10.72-2.2.0_genivi.xml && repo sync), I performed the bitbake compilation and flashed the generated images onto the i.MX8QXP MEK board. Unfortunately, the tools hciattach, hcitool, and hciconfig are not available. I am attaching the folder structure of the 'bld-imx8qxpc0mek/tmp/work/cortexa35-poky-linux/bluez5/5.56-r0/image' below. Kindly go through it and guide me if we need to enable any flags in the Yocto SDK to enable hciattach, hcitool, and hciconfig.

Thanks in advance!

 

 

0 Kudos
Reply

2,433 Views
Harvey021
NXP TechSupport
NXP TechSupport

Hi, 

Which Yocto image target have you built? minimal, or base ...etc. should not include them.

try multimedia or full.

Regards

Harvey

0 Kudos
Reply

2,418 Views
ranjithkumar_kv
Contributor II

Hi Harvey,

 

We are using imx-image-full command for our compilation.

Some warnings we have observed while we are compiling the imx-image-full or bluez5 which we have attached in this reply (bluez5_compilation_warning.png).

Regards,

Ranjith Kumar.

0 Kudos
Reply

2,363 Views
jnj
Contributor III

Hi @Harvey021 ,

While performing 'repo sync,' we encountered an issue with cloning the repository of the meta-ivi layer. Below is the log:

 

Fetching: 75% (12/16) 5:01 | 1 job | 4:27 meta-ivi @ sources/meta-ivi
fatal: unable to connect to github.com:
github.com[0: 192.30.255.113]: errno=Connection timed out


meta-ivi:
fatal: unable to connect to github.com:
github.com[0: 192.30.255.113]: errno=Connection timed out

meta-ivi: sleeping 4.0 seconds before retrying
fatal: unable to connect to github.com:
github.com[0: 192.30.255.112]: errno=Connection timed out
error: Cannot fetch meta-ivi from git://github.com/genivi/meta-ivi
Fetching: 100% (16/16), done in 5m30.794s
Fetching:  0% (0/1) 4:25 | 1 job | 4:25 meta-ivi @ sources/meta-ivi
fatal: unable to connect to github.com:
github.com[0: 192.30.255.113]: errno=Connection timed out


meta-ivi:
fatal: unable to connect to github.com:
github.com[0: 192.30.255.113]: errno=Connection timed out

meta-ivi: sleeping 4.0 seconds before retrying
fatal: unable to connect to github.com:
github.com[0: 192.30.255.113]: errno=Connection timed out
error: Cannot fetch meta-ivi from git://github.com/genivi/meta-ivi
Fetching: 100% (1/1), done in 4m25.551s
fatal: failed to unpack tree object HEAD
error.GitError: Cannot checkout meta-ivi: Cannot initialize work tree for meta-ivi
error: Cannot checkout meta-ivi
Checking out: 100% (16/16), done in 6.921s
error: Unable to fully sync the tree
error: Downloading network changes failed.
error: Checking out local projects failed.
Failing repos:
sources/meta-ivi
Try re-running with "-j1 --fail-fast" to exit at the first error.
================================================================================
Repo command failed due to the following SyncError errors:
GitCommandError: 'fetch --quiet --progress genivi --prune --recurse-submodules=no --tags +refs/heads/:refs/remotes/genivi/ +refs/tags/:refs/tags/' on meta-ivi failed
stdout: fatal: unable to connect to github.com:
GitCommandError: 'fetch --quiet --progress genivi --prune --recurse-submodules=no --tags +refs/heads/:refs/remotes/genivi/ +refs/tags/:refs/tags/' on meta-ivi failed
stdout: fatal: unable to connect to github.com:
Cannot initialize work tree for meta-ivi
 
We have executed 'git config --global url." ".insteadOf git://github.com/' and also performed a separate clone of meta-ivi. However, during compilation, hcitool, hciattach, and hciconfig were not generated. After adding 'deprecated' in the file './meta-ivi/meta-ivi-test/recipes-connectivity/bluez5/bluez5_%.bbappend' as follows:
PACKAGECONFIG += " readline testing tools deprecated"
 
and recompiling, the binaries were generated. Even though the binaries were generated, there are issues with Bluetooth connectivity after flashing the Yocto image onto the device.
 
Kindly help me in resolving the issue.
 
 

 

0 Kudos
Reply

2,358 Views
Harvey021
NXP TechSupport
NXP TechSupport

Hi,

What about using imx-5.10.72-2.2.0.xml if just hcitool needed.

 

Regards

Harvey

0 Kudos
Reply

2,348 Views
jnj
Contributor III

Hi @Harvey021 ,

Sorry .I didn't check with the imx-5.10.72-2.2.0.xml. We  require the meta-ivi layer also.Why can't we fetch the meta-ivi layer?  

0 Kudos
Reply

2,338 Views
Harvey021
NXP TechSupport
NXP TechSupport

Please raise a new case for the meta-ivi layer sync issue.

 

Regards

Harvey

Tags (1)
0 Kudos
Reply

2,324 Views
jnj
Contributor III

Hi @Harvey021 ,

Our main confusion is whether the Bluetooth-related package issues we observed are mainly due to a meta-ivi sync issue.

We have tried with the mentioned imx-5.10.72-2.2.0.xml. We also encountered another fetch issue

 

WARNING: libdrm-2.4.107.imx-r0 do_fetch: Failed to fetch URL git://github.com/nxp-imx/libdrm-imx.git;protocol=https;nobranch=1;branch=libdrm-imx-2.4.107, attempting MIRRORS if available
ERROR: libdrm-2.4.107.imx-r0 do_fetch: Fetcher failure: Fetch command export PSEUDO_DISABLED=1; export DBUS_SESSION_BUS_ADDRESS="unix:path=/run/user/3880/bus"; export

ERROR: libdrm-2.4.107.imx-r0 do_fetch: Fetcher failure for URL: 'git://github.com/nxp-imx/libdrm-imx.git;protocol=https;nobranch=1;branch=libdrm-imx-2.4.107'. Unable to fetch URL from any source.

0 Kudos
Reply

2,203 Views
Harvey021
NXP TechSupport
NXP TechSupport

You can have a try to manually download from the link libdrm-2.4.107 , and to <path-to-build>/downloads. and then touch a copy of it with format like: <filename>.done, without "<>".

 

Regards

Harvey

0 Kudos
Reply