Enable UART3 on imx8qxp-mek

cancel
Showing results for 
Search instead for 
Did you mean: 

Enable UART3 on imx8qxp-mek

589 Views
carlo_p
Contributor II

Hi,

I'm trying to enable the UART3, which, if I'm right, is the one who access the MikroBus Header on the connected MCIMX8-8X motherboard.

In order to do this, according to the schematics, first I had to modify the position of the the 0 ohm resistors R1 and R2, located on the top view of the imx8qxp-mek. This was necessary because, by default, they were connected in order to enable the BB_AUDIO_UART3 signal, instead of the plain UART.

carlo_p_0-1605775933576.png

 

After that, are there any software configuration I need to make (maybe in the DTS files) for having the device ttyLP3 (maybe differently named) show in my devices list?

Tags (4)
0 Kudos
8 Replies

579 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi carlo_p

 

for lpuart3 dts example one can look at:

https://source.codeaurora.org/external/imx/linux-imx/tree/arch/arm64/boot/dts/freescale/imx8x-mek.dt...

 

Best regards
igor

0 Kudos

564 Views
carlo_p
Contributor II

Could you help me please? @igorpadykov ?

0 Kudos

557 Views
igorpadykov
NXP TechSupport
NXP TechSupport

you are right it is enabled by default, no modifications are needed.

 

1.jpg

 

Best regards
igor

0 Kudos

555 Views
carlo_p
Contributor II

ok, then how is it possible that ttyLP3 doesn't show in /dev/ ?

0 Kudos

551 Views
igorpadykov
NXP TechSupport
NXP TechSupport
0 Kudos

546 Views
carlo_p
Contributor II

I'm sorry but this isn't very helpful. I've built the image with yocto without any modification in dts files.

File imx8x-mek.dtsi is identical to the one you've linked. Any idea about something that would prevent ttyLP3 to show in /dev ?

0 Kudos

197 Views
nolan_zinn
Contributor IV

I don't know if you've resolved this yet, but if you're building rpmsg, then lpuart3 is disabled.  See https://source.codeaurora.org/external/imx/linux-imx/tree/arch/arm64/boot/dts/freescale/imx8x-mek-rp...:

&lpuart3 {
	status = "disabled";
};

&uart3_lpcg {
	status = "disabled";
};

If this is your problem, you should consider building the non-rpmsg image from yocto.

 

Regards,

Nolan

0 Kudos

574 Views
carlo_p
Contributor II

Hi, thank you.

The link you posted is the default version of file imx8x-mek.dtsi.

I don't understand which are the modifications to make...

0 Kudos