Enable PU regulator

cancel
Showing results for 
Search instead for 
Did you mean: 

Enable PU regulator

Jump to solution
261 Views
Senior Contributor I

Hi.

I wonder if there is a quick way to enable the PU regulator, either in the device tree or from user space?

For the moment it seems like the PU regulator is disabled (during the startup I can see it first enables and then disables it).

Since it's disabled, the VDDPU won't follow the VDDSOC (which it should according to the datasheet), when changing the frequency (in the imx6q-cpufreq.c file).

If I don't have an application using the VPU, will it automatically disabled the VDDPU?

Thanks,

Niklas

Labels (3)
0 Kudos
1 Solution
35 Views
NXP TechSupport
NXP TechSupport

Hi Niklas

one can check "reg_pu" in imx6qdl.dtsi :

linux-2.6-imx.git - Freescale i.MX Linux Tree

If application is not using the VPU, linux will automatically disable the VDDPU.

Requirement that VDDPU should follow the VDDSOC applies when VDDPU is enabled.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
36 Views
NXP TechSupport
NXP TechSupport

Hi Niklas

one can check "reg_pu" in imx6qdl.dtsi :

linux-2.6-imx.git - Freescale i.MX Linux Tree

If application is not using the VPU, linux will automatically disable the VDDPU.

Requirement that VDDPU should follow the VDDSOC applies when VDDPU is enabled.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
35 Views
Senior Contributor I

Hi Igor.

Thanks for the answer.

I assume that was the case.

Thanks,

Niklas

0 Kudos