Dual display on imx53 WinCE7

cancel
Showing results for 
Search instead for 
Did you mean: 

Dual display on imx53 WinCE7

Jump to solution
892 Views
larson
Contributor III

Hi ,

I am working on imx53 customized board. My problem is I am not able to have two display's at the same time.I want to have both LCD and VGA working at the same and same contents.Please help me out in solving this.

I try to modify the REG to have one of the LDC or the VGA, that is OK. When i have both of them, the code is only check the DI0(pNewModePanelInfo->PORTID) and ingore the DI1, so there is only one can be light. The debug MSG at below:

PID:00400002 TID:0521000E BSPGetNumSupportedModes here NUM_SUPPORTED_PANELS = 5

PID:00400002 TID:0521000E DisplayGetNumSupportedModes here totalModes = 5

PID:00400002 TID:0521000E BSPGetPixelDepthFromRegistry here dwPixelDepth = 16

PID:00400002 TID:0521000E BSPGetPixelDepthFromRegistry here dwPixelDepth = 16

PID:00400002 TID:0521000E GetPanelTypeFromRegistry here regPathString = Drivers\Display\DDIPU\DI0

PID:00400002 TID:0521000E BSPGetPanelInfo here

PID:00400002 TID:0521000E BSPGetPanelInfo NUMBER_PANEL_DI0_PANELS = 1

PID:00400002 TID:0521000E BSPGetPanelInfo panelNum = 0

PID:00400002 TID:0521000E BSPGetPanelInfo NUM_SUPPORTED_PANELS = 5

PID:00400002 TID:0521000E BSPGetSupportedModes here counter = 5

PID:00400002 TID:0521000E GetPanelTypeFromRegistry here regPathString = Drivers\Display\DDIPU\DI0

PID:00400002 TID:0521000E BSPGetPanelInfo here

PID:00400002 TID:0521000E BSPGetPanelInfo NUMBER_PANEL_DI0_PANELS = 1

PID:00400002 TID:0521000E BSPGetPanelInfo panelNum = 0

PID:00400002 TID:0521000E BSPGetPanelInfo NUM_SUPPORTED_PANELS = 5

PID:00400002 TID:0521000E GetPanelTypeFromRegistry here regPathString = Drivers\Display\DDIPU\DI1

PID:00400002 TID:0521000E BSPGetPanelInfo here

PID:00400002 TID:0521000E BSPGetPanelInfo NUMBER_PANEL_DI0_PANELS = 1

PID:00400002 TID:0521000E BSPGetPanelInfo panelNum = 2

PID:00400002 TID:0521000E BSPGetPanelInfo NUM_SUPPORTED_PANELS = 5

PID:00400002 TID:0521000E DisplayGetSupportedModes g_bDI0Connected = 1

PID:00400002 TID:0521000E BSPGetPixelDepthFromRegistry here dwPixelDepth = 16

PID:00400002 TID:0521000E DisplayGetSupportedModes g_bDI1Connected = 1

PID:00400002 TID:0521000E BSPGetPixelDepthFromRegistry here dwPixelDepth = 16

PID:00400002 TID:0521000E BSPGetModeInfo here 1 modeNo = 0

PID:00400002 TID:0521000E DisplayGetPrimaryMode here pNewModePanelInfo->MODEID = 0

PID:00400002 TID:0521000E BSPGetModeInfo here 1 modeNo = 0

PID:00400002 TID:0521000E DisplayGetPrimaryMode here pNewModePanelInfo->MODEID = 0

PID:00400002 TID:0521000E BSPGetVideoPixelDepthFromRegistry here dwVideoPixelDepth = 32, DISPLAY_REG_PATH = Drivers\Display\DDIPU

PID:00400002 TID:0521000E BSPEnableSecondaryPrimarySurface here

PID:00400002 TID:0521000E DisplayEanbleSPrimarySurface here Enable = 1

PID:00400002 TID:0521000E BSPIsRotationSupported here

PID:00400002 TID:0521000E BSPGetC2DInfoFromRegistry here

PID:00400002 TID:0521000E Display IOMUX setted.

PID:00400002 TID:0521000E BSPGetModeInfo here 1 modeNo = 0

PID:00400002 TID:0521000E DisplayGetPrimaryMode here pNewModePanelInfo->MODEID = 0

PID:00400002 TID:0521000E BSPGetModeInfo here 1 modeNo = 0

PID:00400002 TID:0521000E BSPGetModeInfo here 1 modeNo = 0

PID:00400002 TID:0521000E DisplaySetMode: g_pDI0PanelInfo->PANELID = 0

PID:00400002 TID:0521000E DisplaySetMode: g_pDI1PanelInfo->PANELID = 2

PID:00400002 TID:0521000E DisplaySetMode: g_pDI0PanelInfo->PIX_CLK_FREQ = 64995840

PID:00400002 TID:0521000E DisplaySetMode: g_pDI1PanelInfo->PIX_CLK_FREQ = 64995840

PID:00400002 TID:0521000E DisplaySetMode:g_bDI0Connected = 1

PID:00400002 TID:0521000E DisplaySetMode:pNewModePanelInfo->PORTID = 5

PID:00400002 TID:0521000E DisplaySetMode:g_pDI0PanelInfo->PORTID = 5

PID:00400002 TID:0521000E DisplaySetMode:g_bDI1Connected = 1

PID:00400002 TID:0521000E DisplaySetModeg_pDI1PanelInfo->PORTID = 3

PID:00400002 TID:0521000E BSPInitializePanel here

PID:00400002 TID:0521000E BSPInitializeDC here

PID:00400002 TID:0521000E SyncDCConfig here

PID:00400002 TID:0521000E SyncDCConfig + pDIPanelInfo->PORTID = 5, DISPLAY_PORT_VGA= 3

PID:00400002 TID:0521000E BSPInitializeDI here

PID:00400002 TID:0521000E SyncDIConfig here

PID:00400002 TID:0521000E SyncDIConfig pDIPanelInfo->PORTID = 5

PID:00400002 TID:0521000E BSPEnableDisplayClock here

PID:00400002 TID:0521000E BSPEnableDCChannels here

PID:00400002 TID:0521000E LVDSEnablePanel: LVDS come in

PID:00400002 TID:0521000E LVDSEnablePanel: 4

PID:00400002 TID:0521000E DI0->CH1 is not a recommended routine.

PID:00400002 TID:0521000E BSPEnablePanel here

PID:00400002 TID:0521000E DisplaySetMode:BSPEnablePanel

Thanks and Best Regards,

larson

Labels (1)
0 Kudos
1 Solution
153 Views
yossishukron
Contributor III

thank you for the clarification.if you will check the ARD bsp that have LVDS in d0 you will be able to compare it to your files and find out what is wrong.

View solution in original post

0 Kudos
12 Replies
153 Views
yossishukron
Contributor III

you just need to choose dual display in the Catalog.

0 Kudos
153 Views
larson
Contributor III

Hi,

Thanks for your reply, but in the Catalog, the VGA and the LVDS all in the DI1 items, I can only choose one of them, so I change the LVDS to the DI0 in the code, and set the environment variable to the 1, choose the VGA in the Catalog, but  there was only one can be light.

0 Kudos
153 Views
yossishukron
Contributor III

the catalog is allowing LVDS1 in port 0 and LVDS2 or VGA or TVE in port 1 can you explain to me

which display you are trying to put and where ?

0 Kudos
153 Views
yossishukron
Contributor III

in the SMD bsp there is support for HDMI or WVGA in port 0 . and LVDS or VGA or TVE in port 1 maybe it can help you more.

0 Kudos
153 Views
larson
Contributor III

Hi ,

Thanks for your help, I try to use the LVDS at the DI0, and use the VGA at DI1, but that is only one can be display in my code, I move the LVDS to the item DI0, and choose it, but can't work, the attachment is my catalog and the code file, I can set the "PanelType"=dword:0 at the platform.reg below the [HKEY_LOCAL_MACHINE\Drivers\Display\DDIPU\DI0] or [HKEY_LOCAL_MACHINE\Drivers\Display\DDIPU\DI1] to display the LVDS or VGA in the system, but when I set both of them, I can only disply one.

Thanks and Regards!

0 Kudos
153 Views
yossishukron
Contributor III

I am really trying to help you but I think that we have understanding problems the default setup is LVDS in d0 and LVDS or VGA or TVE in d1 . you just need to choose LVDS in d0 and VGA in d1 in the catalog why do you change the code in order to do it. why you can not use the Freescale BSP that already define it.

0 Kudos
153 Views
larson
Contributor III

I am sorry that I can not description clear the problem, I use the imx53 SMD bsp(iMX53_MDK_Mobility), this bsp default setup is LVDS, but in DI1, and the default setup is DVI(HDMI) and WVGA in DI0, LVDS or VGA or TVE in d1, there is no LVDS in DI0. All the code about LVDS is used DI1, the attachment is the code after the modification.

0 Kudos
153 Views
thomasefe
Contributor I

How did u solve it? I have the same issue. Cannot have same image at the same time on DI0 HDMI DI1 LVDS....

I want both to display the same image and resolution on my hdmi and lvds.

SMD bsp but only one display at a time can be activated...I want both on from windows startup.

So no switching between. Just simple two always on with same settings.

Any ideas or tips?

0 Kudos
153 Views
yossishukron
Contributor III

please read the comments before in the ARD BSP you can choose two LVDS displays in the Catalog.

you can check the ARD bsp implementation and do the same in your BSP.

0 Kudos
153 Views
seetha
Contributor III

Hello Yossi Shukron,

In ARD BSP is it possible to have WEC7 on two LVDS connected to different DI's at the same time?

Please confirm. I have SMD BSP I will modify by taking ARD BSP after you confirm.

Regards,

Seetharam

0 Kudos
153 Views
thomasefe
Contributor I

Well the ARD BSP supports DUAL LVDS but this is not my case since I use LVDS+HDMI.

I need one LVDS and one HDMI. Using SMD bsp on a IMX53QSB.

As I said earlier I can switch between these two perfectly fine but how do I get mirroring output on both ports from startup. 800x480 LVDS + 800x480 HDMI(DVI) simultaneously. What is needed to get this to work in the BSP and OS configuration.

0 Kudos
154 Views
yossishukron
Contributor III

thank you for the clarification.if you will check the ARD bsp that have LVDS in d0 you will be able to compare it to your files and find out what is wrong.

View solution in original post

0 Kudos