Dual Lite fails to load realview.inc at -15C

cancel
Showing results for 
Search instead for 
Did you mean: 

Dual Lite fails to load realview.inc at -15C

154 Views
michaelperreca
Contributor II

Good morning,

I am working on a project in which i have to qualify a new DDR3 chip for an existing Dual Lite design.  In doing my testing, I ran the DDR_Stress_Test tool at ambient, -15C, and 60C.  On my first board, at -15C i am unable to get the test to complete. 

What happens is when i download the appropriate realview.inc file into IRAM, the unit reboots as expected but fails to boot properly (i get a "device malfunctioning" notification in windows and the tools spits out that the download has failed.) This occurs with both the command line based 1.0.3 and gui based 2.60. 

To see if this was a fluke i grabbed a second board, and it had no problems completing the tasks at ambient, -15, and 60c.  I grabbed a 3rd board, loaded my linux image onto it and had no problems doing a u-boot mtest at ambient, -15, and 60.

I went back to the failed board and brought it back  down to -15C and still the same issues no matter what I tried.  Every time that board goes to load the image into IRAM it fails.

My assumption is that this is indicative of an iMX issue and not a DDR3 issue but I could be wrong.  Have any other seen this in the past?

The specific part number under test is MCIMC6U7CVM08AC so it should be good to -40C.

Labels (1)
0 Kudos
1 Reply

111 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Michael

if the similar boards work fine, reason may be solder problem on

faulty board. Also one can pay attention to crystals, check if clocks are stable

and look at power supplies. Points for check are given in i.MX6 System Development User’s Guide

https://www.nxp.com/docs/en/user-guide/IMX6DQ6SDLHDG.pdf


Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos