Double screen issue on every few reboots (IMX8MQ based board)

cancel
Showing results for 
Search instead for 
Did you mean: 

Double screen issue on every few reboots (IMX8MQ based board)

115 Views
jemish_1990
Contributor IV

Hi All

  • We are working on product based on IMX8MQ (MIMX8MQ6DVAJZAA) processor.
  • We are using kernel version 4.14.98 and Uboot version 2018.
  • In our product we are operating LCD using eLCDIF controller via MIPI DSI.
  • We are facing strange issue. We observed that after every few reboots we see screen frame out of sync. And sometimes colors also get changed.
  • I am attaching two images as good case and bad case.

Does anyone have any suggestion what can be possible cause for this issue? Any solution or workaround to fix this issue will appreciated.
Let me know if you need more information regarding this issue.

Thanks,

Jemish

Tags (1)
0 Kudos
5 Replies

103 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Jemish

 

for that issue one can try latest silicon revision MIMX8MQ6DVAJZAB, try to

add pause between power off and power on event, to verify that all power supplies

were fully discharged.

 

Best regards
igor

0 Kudos

101 Views
jemish_1990
Contributor IV

Hi Igor,

Thanks for you reply!

This product is already in market so we can not try new revision.

Regarding your suggestion to add pause between power off and power on can you point out some file /function in code so that I can add and verify.

Thanks,

Jemish

0 Kudos

81 Views
jemish_1990
Contributor IV

Hi Igor,

Do you have any suggestion for this issue?

Is there any status register (DSI or ELCDIF controller) which will reflect out of sync video in register bits.

It will help us to understand cause for this out of sync.

Thanks,

Jemish

 

0 Kudos

76 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Jemish

 

I believe there is no software solution. For register settings one can try

to print DSI or ELCDIF controller registers in both good and bad cases.

 

Best regards
igor

0 Kudos

62 Views
jemish_1990
Contributor IV

Hi Igor,

I dumped eLCDIF and DSI registers in good case and bad case but didn't found anything useful. Unfortunately there is not error message for such behavior that could lead to root cause. In our product we added uboot logo support with help from NXP.  After that we started seeing this issue. Before that we didn't observe such issue. Can you give some suggestion based on that?

Thanks,

Jemish

   

0 Kudos