DDR bring up on i.MX6 based SOM

cancel
Showing results for 
Search instead for 
Did you mean: 

DDR bring up on i.MX6 based SOM

123 Views
shivashankar
Contributor II

Hi,

I am using i.MX6D processor on a Nano SOM along side a DDR (POP).

Earlier, we used MT42L128M64LL-25 DDR device but now we want to bring up NT6TL64T64CR from Nanya Tech. Corp., this device is 2Gb in size.

I just want to know how to modify the existing  Mx6DQSDL LPDDR2 Script Aid V0.04 (7).xlsx file for this new device, I tried using the micron's register setting for the new Nanya's device but my u-boot is not booting up.
Please find the attachment for the micron's register setting.

Kindly shed some light on this.

Regards,

Shiva Shankar K.

 

Labels (2)
0 Kudos
3 Replies

112 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Shiva

 

for NT6TL64T64CR one can set number of columns 9 and try ddr test

https://community.nxp.com/t5/i-MX-Processors-Knowledge-Base/i-MX-6-7-DDR-Stress-Test-Tool/ta-p/11082...

 

Best regards
igor

0 Kudos

105 Views
shivashankar
Contributor II

Hi Igor,

I have a couple of points to discuss with you :

1) Do we have a separate 'script aid xlsx' for NT6TL64T64CR device or can we modify the same script aid xlsx file [previously attached] used for MT42L128M64D2 ?

If we have any separate script aid for NT6TL64T64CR , please do share with us?

2) When I use the existing( attached previously) 'script aid xlsx' tool generated script file (.inc file) for micron's  MT42L128M64D2 and use the DDR_STRESS_TESTER_TOOL_V1.0.2 (version 1.0.2) to run the .inc script file, I am getting  a message as below, despite having the board configured for 'Fixed Memory Mapping [0x01]' and it is saying ' 4k interleaved enabled. Not supported by this tool' and the DDR STRESS test stops.[FAILED]

=======DDR configuration==========
BOOT_CFG3[5-4]: 0x02, 4K Interleaved enabled. Not supported by this tool currently.

DDR type is DDR3
Data width: 64, bank num: 8
Row size: 14, col size: 10
Chip select CSD0 is used
Density per chip select: 1024MB
==================================

Interleaved Mode. Not supported!

3) When I run DDR_STRESS_TESTER_TOOL_V1.0.3.1(Version 1.0.3.1) for the same script as used in point (2) (.inc file), then the DDR stress test prompts for user input but I observed few deviations in the message printed while running the test: [DDR test progesses unlike point(2) ]


************************************************************
DDR Stress Test (1.0.3.1) for MX6DQ
This version is only for LPDDR2 4K interleaved mode.   
Build: Oct 17 2014, 16:14:36
Freescale Semiconductor, Inc.
*************************************************************

=================DDR configuration============
BOOT_CFG3[5-4]: 0x02, 4K Interleaved enabled.
Data width: 32, bank num: 8
Row size: 16, col size: 10
Chip select CSD0 is used
Density per chip select: 2048MB
==============================================

             i) The message 'This version is only for LPDDR2 4K interleaved mode'

                 What does it mean? can I still run this 1.0.3.1 version stress tester tool on my board with                          Fixed Mapping DDR?

             ii) The message 'BOOT_CFG3[5-4]: 0x02, 4K Interleaved enabled'

                  Where is this print coming from? Is this from the script register settings? because despite                        configuring my board for Fixed Mapping [0x01] I am getting to see this print.

Kindly help me getting the right script aid and DDR STRESS TESTER tool for the NT6TL64T64CR to 

bring up the u-boot.

 

Regards,

Shiva Shankar K.

 

 

0 Kudos

91 Views
disheng
Contributor III

Hi, you can find the script aid here:

https://community.nxp.com/t5/i-MX-Processors-Knowledge-Base/i-MX6DQSDL-DDR3-Script-Aid/ta-p/1124443/...

 

DDR_STRESS_TESTER_TOOL_V1.0.3.1(Version 1.0.3.1) is for LPDDR2 4K interleaved mode only, you should use 1.03, which can be found here:

https://community.nxp.com/t5/i-MX-Processors-Knowledge-Base/i-MX6-DDR-Stress-Test-Tool-V1-0-3/ta-p/1...

If the calibration still tells you you have 4K interleaved mode configured, probably you need to verify the board again.

Also from Igor's reply, you need to modify the column size to 9, (I have not checked the datasheet but you can verify that).

Hope this is useful for you.

0 Kudos