Could i get iMXPlayer and Video Player demo source code in Yocto

cancel
Showing results for 
Search instead for 
Did you mean: 

Could i get iMXPlayer and Video Player demo source code in Yocto

2,760 Views
arkceajin
Contributor I

Hello

I compiled the Qt Video Widget Player Sample, it can not play the video properly.

Show error: “Qmediaplayer object does not have a valid service”

But the Yocto demo work fine, So where could i get source code of the demo.

Labels (2)
0 Kudos
12 Replies

817 Views
timjaacks
Contributor III

Hi everybody,

you have to add GStreamer to the QtMultimedia PACKAGECONFIG, e.g. by adding the following line to your local.conf:

PACKAGECONFIG_append_pn-qtmultimedia = " gstreamer010"

This makes the QML Video Players (qmlvideo/qmlvideofx) work on our custom board with Yocto 1.6.1 and Qt 5.3.1. I don't know why Freescale does not configure Qt like this in their official BSP.

However, the Qt Widget Video Player (videowidget/videographicsitem) still does not work with this configuration. I do not have any idea how to make this work. It seems as if there is no appropriate GStreamer sink available for this type of application. Has anyone managed to get Video playback work in an iMX6 from a QtWidgets application?

Freescale's imxplayer does not make use of QtMultimedia for playing videos at all. Instead, it uses the gstreamer API directly. You can see that in the fslqtapplications recipe, gstreamer is listed as a dependency there. Calling objdump on the imxplayer binary shows this dependency as well.

So yeah, Freescale, I would like to join the initial question and even ask some more:

   1. Is the imxplayer source code available somewhere?

   2. Why is it included in Yocto as binary at all? Is there anything special inside?

   3. Why did you choose to use the GStreamer API directly instead of using QtMultimedia?

Best regards,

Tim

0 Kudos

817 Views
arkceajin
Contributor I

Hi Tim

     Thanks for you answering, i am trying your solution, but i did not get the mean 'QtMultimedia PACKAGECONFIG'.

Do i need add the command before bitbake. Or after compile Qt , recompile QtMultimedia.

Where i suppose put the line.

   

Ark

0 Kudos

817 Views
timjaacks
Contributor III

Hi Ark,

did you read the complete sentence? I posted the exact line you have to add to your local.conf in order to achieve this.

Tim

0 Kudos

817 Views
arkceajin
Contributor I

Hi Tim

     Sorry, Tim, i was confuse when shall i put that into local.conf.

I guess first i suppose to modify the local.conf, then bitbake again.

Ark

0 Kudos

817 Views
timjaacks
Contributor III

Of course you have to re-run bitbake after modifying your local.conf.

0 Kudos

817 Views
arkceajin
Contributor I

Hi Tim

Finally, it worked for both QMediaPlayer and QML (qmlvideo/qmlvideofx) demo, I added the line into local.conf.

but got the "no qmultimedia" error for QML demo.

Then added these into local.conf.

IMAGE_INSTALL_append = " \

    qtmultimedia \

    qtmultimedia-plugins \

    qtmultimedia-examples \

    qtmultimedia-qmlplugins \

    "

QML got work, and QMediaPlayer demo put the video into QGraphiceSence instead of QVideoWidget, also worked.

By the way, QMediaPlayer was able to play the video, but still got some warning about the gstreamer buffer,and the video performance was awful.

QML was pretty good.

Ark

0 Kudos

817 Views
ruiguifang
Contributor III

HI,

     I meet the same situation to you,the qml got work pretty good , but no voice output, how can i set the voice trannle  on qml.any reply is ok.thx

0 Kudos

817 Views
luisrobertotogo
Contributor II

I have exactly the same problem.

Using Yocto 1.7.2 and QT5.3.2.

Is there any solution to this problem?

0 Kudos

817 Views
jamesbone
NXP TechSupport
NXP TechSupport
0 Kudos

817 Views
arkceajin
Contributor I

Hi James

     These examples is exactly i tried, and the media video file for testing is Mp4.

looks like "libgstmediaplayer.so" and "gstreamer" lib is necessary for project compiling.

So is there any tutorial for gstreamer?

0 Kudos

817 Views
cigdemyavuzcayc
Contributor I

Hi,

I am using yocto project 1.8 fido edition and kernel version 3.14.28. I am running videowidget example project on sabre board and I am getting the same error "The QMediaPlayer object does not have a valid service". Did you solve the problem?

Kind regards,

Cigdem

0 Kudos

817 Views
arkceajin
Contributor I

Hello Cigdem

Sorry, Still not get the solution. no idea for installing the "gstreamer" and "QGStreamer" into building system.

ark

0 Kudos