Compile error for bitbake meta-toolchain——L5.15.71_2.2.0

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Compile error for bitbake meta-toolchain——L5.15.71_2.2.0

667 Views
pengluo
Contributor III

I have recevied this below error message during the compilation of meta-toolchain, How to resolve this issue,

Command used : bitbake meta-toolchain and bitbake meta-toolchain-qt6

NOTE: Executing Tasks
ERROR: meta-toolchain-1.0-r7 do_populate_sdk: The postinstall intercept hook 'update_mime_database' failed, details in /work2/imx-yocto-5.15.71-2.2.0/build-wayland/tmp/work/armv8a-poky-linux/meta-toolchain/1.0-r7/temp/log.do_populate_sdk
ERROR: Logfile of failure stored in: /work2/imx-yocto-5.15.71-2.2.0/build-wayland/tmp/work/armv8a-poky-linux/meta-toolchain/1.0-r7/temp/log.do_populate_sdk.20880
ERROR: Task (/work2/imx-yocto-5.15.71-2.2.0/sources/poky/meta/recipes-core/meta/meta-toolchain.bb:do_populate_sdk) failed with exit code '1'
NOTE: Tasks Summary: Attempted 3787 tasks of which 3779 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
/work2/imx-yocto-5.15.71-2.2.0/sources/poky/meta/recipes-core/meta/meta-toolchain.bb:do_populate_sdk
Summary: There was 1 WARNING message.
Summary: There was 1 ERROR message, returning a non-zero exit code.

0 Kudos
2 Replies

662 Views
pengluo
Contributor III
 
0 Kudos

644 Views
joanxie
NXP TechSupport
NXP TechSupport

pls refer to the link as below:

https://community.nxp.com/t5/S32G/bsp30-0-build-err-in-fsl-image-auto-1-0-r0-do-rootfs/m-p/1373109

I suggest that you can refer to the yocto user guide, and check if your ubuntu build environment install all of packages or not

 

0 Kudos