Compile Problem (L3.0.35_4.1.0 on Ubuntu 14.04 64bit OS)

cancel
Showing results for 
Search instead for 
Did you mean: 

Compile Problem (L3.0.35_4.1.0 on Ubuntu 14.04 64bit OS)

534 Views
Contributor III


Hi. I am using VMware for Ubuntu-14.04.3-desktop-amd64.iso

and I install L3.0.35_4.1.0_130816_source.tar.gz

I tried to patch and refer to Compile L3.0.35_4.1.0 on Ubuntu 13.10 64bit OS

But When i write $ git apply 0001_make_L3.0.35_4.1.0_compile_on_Ubuntu_14.04_64bit_OS.

There are Errors about patch Fail.

Help me Please

----------------------------------------------------------------------------------------

kyg@ubuntu:~/ltib$ git apply 0001_make_L3.0.35_4.1.0_compile_on_Ubuntu_14.04_64bit_OS.patch

0001_make_L3.0.35_4.1.0_compile_on_Ubuntu_14.04_64bit_OS.patch:106: trailing whitespace.

%patch1 -p1

0001_make_L3.0.35_4.1.0_compile_on_Ubuntu_14.04_64bit_OS.patch:144: trailing whitespace.

0001_make_L3.0.35_4.1.0_compile_on_Ubuntu_14.04_64bit_OS.patch:164: trailing whitespace.

0001_make_L3.0.35_4.1.0_compile_on_Ubuntu_14.04_64bit_OS.patch:166: trailing whitespace.

0001_make_L3.0.35_4.1.0_compile_on_Ubuntu_14.04_64bit_OS.patch:169: trailing whitespace.

error: patch failed: bin/Ltibutils.pm:359

error: bin/Ltibutils.pm: patch does not apply

error: patch failed: dist/lfs-5.1/base_libs/base_libs.spec:296

error: dist/lfs-5.1/base_libs/base_libs.spec: patch does not apply

error: patch failed: dist/lfs-5.1/m4/m4.spec:9

error: dist/lfs-5.1/m4/m4.spec: patch does not apply

error: patch failed: dist/lfs-5.1/ncurses/ncurses.spec:31

error: dist/lfs-5.1/ncurses/ncurses.spec: patch does not apply

error: patch failed: dist/lfs-5.1/openssl/openssl.spec:10

error: dist/lfs-5.1/openssl/openssl.spec: patch does not apply

error: patch failed: dist/lfs-5.1/xorg-server/xorg-server.spec:11

error: dist/lfs-5.1/xorg-server/xorg-server.spec: patch does not apply

error: pkgs/m4-1.4.16-1383761043.patch: already exists in working directory

error: pkgs/m4-1.4.16-1383761043.patch.md5: already exists in working directory

error: pkgs/openssl-1.0.1c-1398677566.patch: already exists in working directory

error: pkgs/openssl-1.0.1c-1398677566.patch.md5: already exists in working directory

error: pkgs/xorg-server-1.6.1-1398785267.patch: already exists in working directory

error: pkgs/xorg-server-1.6.1-1398785267.patch.md5: already exists in working directory

0 Kudos
1 Reply

33 Views
NXP TechSupport
NXP TechSupport

Hello Dav Jo

If at all possible I would recommend reverting switching to the exact Ubuntu version of the document you’re referring to (https://community.nxp.com/docs/DOC-98911) since LTIB is very sensitive to packet versions.

If you look at the documentation that is bundled with the L3.0.35_4.1.0 LTIB latest supported Ubuntu version for the host was 9.0.4 which is not too old for most to use. Most community users were able to adapt it to work on Ubuntu 11.04 and there are also some Community Documents for Ubuntu 12.04 (https://community.nxp.com/docs/DOC-93454) but unfortunately nothing yet for Ubuntu 14.04.

Regards,

0 Kudos