Capturing analog video with imx6q and tvp5150 decoder

cancel
Showing results for 
Search instead for 
Did you mean: 

Capturing analog video with imx6q and tvp5150 decoder

362 Views
dugurlu
Contributor I

Hi Everyone

I am working on a project which is about capture video.

When the system starts(Video input enable) everything is good.  The video seems to start at top of the monitor. Everything is flawlessly but the system starts(video input disable) and then the video cable connects to the system. The video seems to start at the CUSTOM location of the monitor.  The video starts sometimes the center of the monitor, sometimes bottom of the monitor.

How can ı solve this problem?

Video input source:   NTSC
Video input decoder: TVP5150
Video input encoder: adv7391

Linux Kernel: 3.14.28 

0 Kudos
3 Replies

227 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi dogan

 

I am afraid there is no good way for solution, in general one can restart

"Video input enable" application.

 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

227 Views
dugurlu
Contributor I

Thanks for your reply.

So how can ı detect this case? I couldn't access tvp5150 register with i2cget, i2cget. Because of kernel blocks access tvp5150 registers. 

Is there another way to reach tvp5150 registers? or how can  I detect this case?

0 Kudos

227 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi dogan

 

I am afraid there is no way to detect in software event when image become shifted.

Best regards
igor

0 Kudos