Cannot download BSP 3.10.17 (Yocto)

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot download BSP 3.10.17 (Yocto)

1,749 Views
faisaltaj
Contributor II

Hi,

I have wasted plenty of time trying to work around a way to get through this problem. I am exactly following Freescale_Yocto_Project_User's_Guide.pdf instructions to get hold of Yocto Project layers but no matter what I do, end result is always same:

after configuring git with name and email add:

I executed this:

ubuntu@ubuntu:$ repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-3.10.17-1.0.2_ga

result:

fatal: cannot obtain manifest git://git.freescale.com/imx/fsl-arm-yocto-bsp.git

Yes I am behind proxy server. One solution I found looking around was to configure git with further parameters:

git config --global http.proxy http://proxyuser:proxypwd@proxy.server.com:8080proxypwd@proxy.server.com:8080

git config --global https.proxy https://proxyuser:proxypwd@proxy.server.com:8080proxypwd@proxy.server.com:8080

did that too, but still the same result.

Have anyone before had faced this scenario? Please help when you got it fixed.

Thanking in advance.

Faisal

Labels (3)
Tags (3)
0 Kudos
3 Replies

510 Views
franckmaillot
Contributor I

Hello,

use http://git.freescale.com/git/cgit.cgi/imx/whatever.git instead. It looks like a cgi script is used to give you access to the git repository over http.

git config http_proxy is still required.

Regards,

Franck

0 Kudos

510 Views
rodrigoaldana
Contributor I

Hi Faisal,

I think the problem the problem is in your proxy configuration,

You might find this link useful:

https://wiki.yoctoproject.org/wiki/Working_Behind_a_Network_Proxy

Regards,

Rodrigo

510 Views
gusarambula
NXP TechSupport
NXP TechSupport

rodrigoaldana, would you please help on this?

0 Kudos