Can't get: gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12-1.i386.rpm at ./ltib line 2560.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't get: gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12-1.i386.rpm at ./ltib line 2560.

Jump to solution
5,832 Views
carlosorriento
Contributor II

Trying to get a successful build without success

Built a VirtualBox VM with Ubuntu 9.04 32-bit.

Ran through all the steps from the "Setting Up a Linux Host for LTIB Builds on Ubuntu 9.04" Rev. L2.6.35_1.1.0, 02/2013

Then moved on to "i.MX28 EVK Linux User’s Guide" Rev. L2.6.35_1.1.0 02/2013

pull down L2.6.35_1.1.0_130130_source.tar.gz, unpack to a convenient directory

enter L2.6.35_1.1.0_130130_source directory

per the instructions, untar ltib.tar.gz

run ./install  (which I think untars tlib.tar.gz again, but so what)

Looks fine "Installation complete, your ltib installation has been placed in /home/jim/ltib, to complete the installation:" etc.

change to the ltib directory

execute ./ltib

As expected, it chugs away, compiling bits and pieces

Menu pops up, I select “Freescale iMX reference boards” , exit,save

Another menu pops up, I select "mx28" and Minimum bootable root F/s, exit, save

"iMX28 Based board" mernu pops up

accept defaults, exit, save

*** End of configuration.

*** Check the top-level Makefile for additional configuration options.

+ cp .config defconfig.dev

CONFIG_TOOLCHAIN forced a full rebuild

Installing: gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12-1.i386.rpm

Testing network connectivity

OK GPP:

Try gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12-1.i386.rpm.md5 from the GPP

http://bitshrine.org/gpp/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12-1.i386.rpm.md5:

21:59:11 ERROR 404: Not Found.

Try gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12-1.i386.rpm from the GPP

http://bitshrine.org/gpp/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12-1.i386.rpm:

21:59:11 ERROR 404: Not Found.

Can't get: gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12-1.i386.rpm at ./ltib line 2560.

Died at ./ltib line 2560.

traceback:

main::check_toolchain_setup:2560

  main::pre_build_checks:1465

   main:569

Started: Sun Mar  3 21:17:48 2013

Ended:   Sun Mar  3 21:59:11 2013

Elapsed: 2483 seconds

Build Failed

Exiting on error or interrupt

jim@jim-laptop:~/ltib$

any ideas?

1 Solution
1,346 Views
jordifarres
Contributor III

Hi,

I had the same problem, and I've solved it just changing the toolchain in the configuration:

$./ltib -m config

in the Toolchain selection I've choosed:
"ARM, gcc-4.4.4, multilib, neon optimized"
instead of default
"ARM, gcc-4.6.2, multilib, neon optimized, gnueabi/eglibc2.13".
The compilation build succesfully.
I hope this help you


View solution in original post

2 Replies
1,347 Views
jordifarres
Contributor III

Hi,

I had the same problem, and I've solved it just changing the toolchain in the configuration:

$./ltib -m config

in the Toolchain selection I've choosed:
"ARM, gcc-4.4.4, multilib, neon optimized"
instead of default
"ARM, gcc-4.6.2, multilib, neon optimized, gnueabi/eglibc2.13".
The compilation build succesfully.
I hope this help you


1,346 Views
soojinlee
Contributor I

thank you very mach !!

your answer is correct!