Can't build AVS for Jethro or Morty on IMX7d

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't build AVS for Jethro or Morty on IMX7d

332 Views
martinleisner
Contributor I

Following the instructions here:

Build Alexa SDK (AVS) image for i.mx7D PicoPi board (using Jethro Yocto) 

when I try to build for Jethro, I have a problem fetching the kernel (the tag is unknown)

The original kernel rev was:

d2e98efca60e21ad1b835f0960b5d86009356d69

that's not there anymore (it worked about a month ago),

I had to use:

cca1dee462d96ccabcf072a1d2d4a00ba50f2d81

which looked like an equivalent commit (close to the same comment, but not exactly) -- I still need to compare the kernels manually.

I'm just puzzled how a commit went away (same git repo, same branch).

When I build morty with these instructions:

Build Alexa SDK (AVS) image for i.mx7D PicoPi board (with Yocto Morty, Kernel4.9) 

I can't enable AVS.

When I execute the rule:

ERROR: avs-image-1.0-r0 do_rootfs: Function failed: do_rootfs

I get:

1704:Installing perl-module-e.. ######################################## [ 99%]
1705:Installing perl-module-e.. ######################################## [ 99%]
1706:Installing perl-module-e.. ######################################## [100%]
error: Unknown error

util-linux-sfdisk
util-linux-sulogin
util-linux-swaponoff
util-linux-umount
v4l-utils

Naturally, unknown error isn't very helpful.

Labels (2)
0 Kudos
3 Replies

157 Views
diegoadrian
NXP Employee
NXP Employee

Hello,

Do you have your init.rc file? There is some configuration that needs to be done on that file. Because the space assigned to the file system is not enough and you need to add the command to assign the extra space.

Best regards,

Diego.

0 Kudos

157 Views
martinleisner
Contributor I

I'm not sure what you want by init.rc.

I've also found core-image-minimal doesn't build (same type of problem) if you select avs -- no problem without avs.

jethro built fine -- I'm going to look at the differences....

marty

0 Kudos

157 Views
diegoadrian
NXP Employee
NXP Employee

Hello,

I apologize, I saw that I misunderstood the file name, the local.conf is the needed file, there you can assign more memory to the rtfs.

I apologize for the misunderstanding.

Best regards,

Diego.

0 Kudos