Calling issue using bluetooth on the i.MX8QUADMAX board with Murata 1cx module

cancel
Showing results for 
Search instead for 
Did you mean: 

Calling issue using bluetooth on the i.MX8QUADMAX board with Murata 1cx module

301 Views
Arvi
Contributor I

Hi,

I have been trying to connect phone on the i.MX8QM development board with Bluetooth module Cypress CYW4356. My phone is connected to the board and i am able access the caller app. Using i made a call to another device and calling is done. But no audio is getting in both devices, which i guess some issues in routing call from the board. The board is connected with a speaker system and we can able able play a music from phone via Bluetooth using an app (media player). I don't think Bluetooth has any issue. Could you suggest a method so that i can able to use Bluetooth for telephonic purpose. Thank you.

Regards,

Aravind.

0 Kudos
6 Replies

287 Views
IvanRuiz
NXP TechSupport
NXP TechSupport

Hello,

 

If the board is able to play audio from BT then the problem might be on the call app, because:

*Audio on the board working (Possible)

*Send audio over Bluetooth (Possible)

 

Please try to use another app for the call.

 

BR,

Ivan.

0 Kudos

275 Views
Arvi
Contributor I

First of all sorry, there is a misunderstanding in defining the Audio issue. Actually if we connect our mobile device with i.MX8 Board using Bluetooth, it's not transferring any audio sources including media sources like music, Video. If we play music, it suddenly gets paused. Same for video also but if we call, the connection gets established. But still audio is not working. But from the i.MX8 Board if we play music that is in its memory using a media player then it comes out from the speaker connected. Thank you.

0 Kudos

266 Views
IvanRuiz
NXP TechSupport
NXP TechSupport

Hello,

 

Then the problem seems to be in the BT module. You may find it helpful to refer to the following document from Murata, chapter 7.2 for testing/verifying of BT interface: https://wireless.murata.com/pub/RFM/data/murata_quick_start_guide_linux.pdf

Hope it helps you find the problem!

BR,

Ivan.

0 Kudos

182 Views
Arvi
Contributor I

Hi,

As you suggested i tested and verified the Bluetooth module and found its working perfectly. From i.MX side i am getting some failure and error. I am attaching the logfile for bluetooth call. I made some edit in audio_policy_configuration.xml file in-order to enable audio devices. I am sending logfiles with and without xml edits. telephony_call.txt is logfile with edit in audio_policy_configuration.xml. Please find the attachments. Thank you.

Regards,

Aravind.

0 Kudos

239 Views
Arvi
Contributor I

Hi,

I found the audio_policy_configuration.xml from my i.MX8QMMEK board. From my understanding its required to add every device ports and routes of every audio devices in that .xml file in order to enable the audio devices.

But in my audio_policy_configuration.xml file the device ports, sink and source details are not added for telephone call audio sources. AUDIO_DEVICE_OUT_TELEPHONY_TX and AUDIO_DEVICE_IN_TELEPHONY_RX are missing.

I am attaching the file for your reference. So i want to know whether this is the reason why am not getting the audio while calling through Bluetooth. Thank you.

Regards,

Aravind.

0 Kudos

273 Views
Arvi
Contributor I

Hi,

Please find the Bluetooth HCI snoop log attached for your reference.

 

Regards,

Aravind.

0 Kudos