CPU utlisation goes 100% in SABRE/WinCE7 while running standard 2d DirectX application.

cancel
Showing results for 
Search instead for 
Did you mean: 

CPU utlisation goes 100% in SABRE/WinCE7 while running standard 2d DirectX application.

1,205 Views
DeepakNaik
Contributor I

I am struggling on an issue wherein any application which uses DirectX consume 100 % CPU power resulting no room for other activities on SABRE/WinCE7 platform. We tested standard 2D DirectX application such as donut.exe (direct draw 2 d app from Microsoft). However I have also tested 3d application (Cube.exe )provided by freescale. It works fine utilizing 40% cpu utilization.

We have also checked in BSP that there are catalog items for GPU component( Direct3d, openGl es, openVG support). Implementation for GPU component are not available as it is dll and lib format.

Does any body face this problem?

 

-Deepak Naik

Labels (1)
Tags (2)
0 Kudos
4 Replies

323 Views
iMXAndrew
Contributor II

Seetharam or Deepak,

 

Check the BSP documentation. It is under GPU if I remember right. I think you need to set in your project Properties Enviroment Variables: Variable: BSP_Display_Z430 Value:1

Also, I think you need to enable in BSP in Third Party. GPU :OpenGL ES Support and if you you are using Silverlight components you also need to enable XAMLRENDERPLUGIN: OPENGL ZAML Render Plug-in by Microsoft and OPENGL ZAML Render Plug-in optimized for i.MX53.

 

Hope this helps.

0 Kudos

323 Views
seetha
Contributor III

Hi Deepak, 

How do I enable direct 3D in my platform? SYSGEN_D3DM, SYSGEN_D3DMREF and SYSGEN_D3DMXSCALE variables are not at all there in my OS design. Do you have any idea why these variables are not present in my design. When I hard code d3dm_ati.dll in my platform.bib file of release directory, I get following errors.


Error: Can't find import rb_surface_alloc in librenderboy.dll {log="C:\WINCE700\build.log(1208)"}
C:\WINCE700\build.log(1209) : Error: Can't find import rb_surface_alloc hint 81 in librenderboy.dll {log="C:\WINCE700\build.log(1209)"}
C:\WINCE700\build.log(1210) : Error: Fatal import error in d3dm_ati.dll {log="C:\WINCE700\build.log(1210)"}
C:\WINCE700\public\common\oak\misc\makeimg.proj(680,5): error MSB3073: The command "romimage C:\WINCE700\OSDesigns\iMX53_EVK_Mobility\RelDir\Freescale_i_MX53_SMD_ARMV7_Release\ce.bib " exited with code 1. {log="C:\WINCE700\build.log(1212)"}
C:\WINCE700\public\common\oak\misc\makeimg.proj(680,5): error MSB3073: The command "romimage C:\WINCE700\OSDesigns\iMX53_EVK_Mobility\RelDir\Freescale_i_MX53_SMD_ARMV7_Release\ce.bib " exited with code 1. {log="C:\WINCE700\build.log(1219)"}

Please let me know if you have any solution to solve this. I suspect these errors because of absence of those sysgen variables in my OS design.

Please help me to add direct 3D mobile support into my OS image.

Thanks

With Regards,

Seetharam


0 Kudos

323 Views
DeepakNaik
Contributor I

I have downloaded FSL release and include in my build with sysgen. Still the problem persist. I am using remote performance monitor to test the stadard 2D microsoft application on it.

Further help will be appreaciated.

 

Regards,

Deepak

0 Kudos

323 Views
StanleyLee
NXP Employee
NXP Employee

FSL released a patch for i.mx53 wince to fix some GPU issues. Please go to FSL office web to download then and have a try.

0 Kudos